unable to dnd link from html email in tbird to personal toolbar or bookmark organizer

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
10 months ago

People

(Reporter: moco, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Bug Flags:
in-litmus ?

Firefox Tracking Flags

(Not tracked)

Details

unable to dnd link from html email in tbird to personal toolbar or bookmark organizer

steps to reproduce:

1)  view an html email in tbird with something like <a href="http://www.foo.com">blah blah</a> in the html body
2)  drag and drop that link to the personal toolbar or bookmark organizer
3)  we allow you to drop, but fail to insert the link

when dropping to the personal toolbar, I see this in my console:

JavaScript error: , line 0: uncaught exception: [Exception... "Component returne
d failure code: 0x804b000a [nsIIOService.newURI]"  nsresult: "0x804b000a (<unkno
wn>)"  location: "JS frame :: chrome://browser/content/places/utils.js :: PU__ur
i :: line 196"  data: no]

when dropping to the organizer, I don't see anything (but we could be try / catching and eating the exception)

I would except this to work similar to what happens when dragging html links from web pages to the personal toolbar or bookmark organizer

tbird version 2.0.0.7pre (20070803)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007081015 Minefield/3.0a8pre

speculation:

I haven't debugged, but we might think the clipboard data is text/unicode, and try to verify it is a url (using the io service) and that fails.  maybe we have html?  I would think that we would have some text/x-moz-url data on the clipboard?
Flags: in-litmus?
this is WFM. i'm not marking of duplicate of bug 379553, instead morphing that to cover only textedit links.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
this still doesn't work for me, with tbird 200x, trunk, windows xp and a <a href> in an html email.

dietrich, did you try that?

re-opening.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
The difference was that i was on Mac OSX and it was a bugmail, which is actually text. Gah, i totally shouldn't have closed this.
Ok, so now i tried using HTML email, and I got a bookmark on the toolbar, but it didn't take the title from the HTML email, used the URL instead.
Status: REOPENED → NEW
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
I've just tried this on Windows & Mac, and everything works as expected with drag and drop. I suspect this got fixed along the way somewhere.
Status: NEW → RESOLVED
Last Resolved: 11 years ago10 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.