slow to copy lots of nested bookmarks

RESOLVED DUPLICATE of bug 472343

Status

()

P3
normal
RESOLVED DUPLICATE of bug 472343
11 years ago
8 years ago

People

(Reporter: moco, Unassigned)

Tracking

({perf})

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +
wanted-firefox3.6 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TSnappiness])

slow to copy lots of nested bookmarks

steps to reproduce:

1) have a profile with lots of bookmarks with subfolders
2) open bm organizer, select all, copy

you will get the busy cursor and firefox will not be responsive.

I am seeing is lots of command updating.  updating could be happening as we expand and collapse folders recursively when we wrap nodes?
Flags: blocking-firefox3?
Flags: blocking-firefox3? → blocking-firefox3+
> I am seeing is lots of command updating.

boris recently logged a bug about command updating, and mano fixed it (see bug #394695)

Mano may have fixed this bug as well, it would be worth re-testing.
Depends on: 394695
Target Milestone: --- → Firefox 3 M10

Updated

11 years ago
Target Milestone: Firefox 3 M10 → Firefox 3 M11
Target Milestone: Firefox 3 Mx → Firefox 3 M11
Lots of perf improvements to the wrap/unwrap code in bug 384370, may mitigate this bug.
Target Milestone: Firefox 3 M11 → Firefox 3 Mx

Updated

11 years ago
Priority: -- → P5

Updated

11 years ago
Flags: wanted-firefox3+
Flags: blocking-firefox3-
Flags: blocking-firefox3+
Priority: P5 → P4
Target Milestone: Firefox 3 Mx → Firefox 3 M11
Seth: is this still reproducible?
Target Milestone: Firefox 3 beta3 → ---

Comment 4

11 years ago
i've seen this recently so i think it's still reproducible, when doing copy/paste or draggin a big folder with many entries and subfolders we are still slow. But IIRC there's also another bug on this
Whiteboard: [Related: 329534, 393497, 397993, 432706]
Depends on: 432706

Comment 5

10 years ago
Me too. I don't even have to select all of my bookmarks - one folder is enough to load this P4/2.6GHz for a minute.

X11; U; Linux i686; en-US; rv:1.9.0.4 Gecko/2008111318 Ubuntu/8.10 (intrepid) Firefox/3.0.4
Flags: wanted-firefox3.5+
Priority: P4 → P3
Flags: wanted-firefox3.5+ → wanted-firefox3.6+

Updated

9 years ago
Blocks: 393497

Updated

9 years ago
Whiteboard: [Related: 329534, 393497, 397993, 432706]

Updated

9 years ago
Whiteboard: [TSnappiness]
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks

Comment 7

8 years ago
Sorry for spamming but are you still seeing this, after bug 472343 was fixed?
Let's call this a dupe, the code changed pretty much and it's hard to link this bug to the original cause.
We have other bugs handling missing perf gains.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 472343
You need to log in before you can comment on or make changes to this bug.