bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

view page info -> links are missing!

VERIFIED WONTFIX

Status

()

Firefox
Page Info Window
--
enhancement
VERIFIED WONTFIX
11 years ago
9 years ago

People

(Reporter: patrickdrd, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007081105 Firefox/2.0 MEGAUPLOAD 1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007081105 Firefox/2.0

Hi everyone!

Where has that disappeared?
Any way to get it back because it was useful to me?

Thanks in advance!

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

I see them all. Please retest in Firefox's safe-mode, with a new profile or try a reinstall in a new empty folder.

http://kb.mozillazine.org/Safe_Mode_(Firefox)
http://kb.mozillazine.org/Profile_Folder

Comment 2

11 years ago
It should be in the trunk, not branch. But why the User-Agent say it is Firefox/2.0?
Flags: blocking-firefox3?
(Reporter)

Comment 3

11 years ago
I have changed my user-agent to add the "megaupload" string,
it's a trunk indeed: minefield 2007081105,
it's not fx 2.0,
see here too:
http://forums.mozillazine.org/viewtopic.php?p=3008197#3008197
(Reporter)

Updated

11 years ago
Severity: normal → enhancement
Version: unspecified → Trunk

Comment 4

11 years ago
i don't know if the new info page did not include links by design, if not this is a regression from branch

cc-ing Florian, he should know about it
(Reporter)

Comment 5

11 years ago
many people, like me, want the links of in "page info" back!

please include them inside page info, we need them
(In reply to comment #4)
> i don't know if the new info page did not include links by design, if not this
> is a regression from branch
> 
> cc-ing Florian, he should know about it
> 

Yes, the Links tab has been removed by design. Same thing for the Forms tab.
I plan to write an extension adding them back, so that this decision doesn't hurt to much people who were using them.
(Reporter)

Comment 7

11 years ago
thanx! we need them back!

Comment 8

11 years ago
So, Florian, should this be marked as a wontfix?
(In reply to comment #8)
> So, Florian, should this be marked as a wontfix?
> 

yes
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Flags: blocking-firefox3?
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → WONTFIX

Updated

11 years ago
Status: RESOLVED → VERIFIED

Updated

10 years ago
Duplicate of this bug: 432445

Comment 11

10 years ago
Florian, 2007-08-13: "Yes, the Links tab has been removed by design. Same thing for the Forms tab. I plan to write an extension adding them back, so that this decision doesn't hurt to much people who were using them."

Any progress with that extension Florian?  This hurts (see Bug 432445). It's the "Links" tab I miss -- it was so very useful.
(In reply to comment #11)

> Any progress with that extension Florian?

I haven't worked on it yet, but it should be easy to do.  I still think I will release it before Firefox 3 final ships.
The "Links and Forms" extension is now available on AMO in the sandbox at:
 https://addons.mozilla.org/en-US/firefox/addon/7459

Comment 14

10 years ago
Thanks Florian, great job!  Works a treat!
Duplicate of this bug: 438936

Comment 16

10 years ago
Thanks for the quick comment on Bug 438936 !

I have a question, though: the URL 

https://addons.mozilla.org/en-US/firefox/addon/7459

does not provide a download link.

The .xpi link instead points to a user registration page.

Do users now have to register to regain functionality that was available in FF2.0 without registration?
You have to register to download it because this add-on is currently still in the sandbox.

Some explanations on the sandbox system:
https://addons.mozilla.org/en-US/firefox/pages/sandbox
Duplicate of this bug: 441685

Comment 19

10 years ago
Wow. Removing those tabs was almost as useful as removing MNG support. Thanks Firefox team. You always know what to do to improve the user experience.
Duplicate of this bug: 459427

Updated

9 years ago
Duplicate of this bug: 492246
Duplicate of this bug: 505753
You need to log in before you can comment on or make changes to this bug.