"ASSERTION: we're not in galley mode" in nsTableRowGroupFrame::SlideChild with -moz-column and img

VERIFIED WORKSFORME

Status

()

defect
VERIFIED WORKSFORME
12 years ago
10 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

(Blocks 1 bug, {assertion, testcase})

Trunk
x86
macOS
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Posted file testcase
Loading the testcase triggers:

###!!! ASSERTION: we're not in galley mode: 'NS_UNCONSTRAINEDSIZE == aReflowState.reflowState.availableHeight', file /Users/jruderman/trunk/mozilla/layout/tables/nsTableRowGroupFrame.cpp, line 876
wfm?
WFM on Mac.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
Flags: in-testsuite+
i updated the test to use about:blank instead of http://i as the image. I confirmed that the change reproduced the original crash for me. This prevented timeouts caused by the failure to load the non-existent image.

http://hg.mozilla.org/mozilla-central/rev/a1e84240b5c9
You need to log in before you can comment on or make changes to this bug.