cursor/caret dissappeares from css styled textarea

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: jonas-e, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

When textareas / inputs and the divs they are contained within are styled - possibly when they are positioned absolutely - the cursor/caret disappears. You can view the bug on the the URL above, but PLEASE do not submit the form / alter the database! 
If the css file is not imported, the problem does not occur. The problem does not occur in IE7, Opera or win-Safari.
Forums on the internet suggest to add overflow:auto to those divs but that does not resolve the problem.

Reproducible: Always

Steps to Reproduce:
1. Load http://ellehauge.net/cms_cv_new.php?edit_id=104.
2. Click and edit the input or textareas.
3. The cursor/caret is gone.
Actual Results:  
No cursor / caret.

Expected Results:  
Visible cursor / caret.
I see this with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.7pre) Gecko/20070801 BonEcho/2.0.0.7pre but not with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a8pre) Gecko/2007081203 Minefield/3.0a8pre ID:2007081203

Please test with a trunk build, and if you see the caret as expected, then mark this bug WORKSFORME (Fixed for firefox 3)
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

Updated

11 years ago
Version: unspecified → 2.0 Branch
(Reporter)

Comment 2

11 years ago
OK. It works with 3.0a8pre.
When will forefox 3 be released?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
My current _guess_ is either late November 2007 or early February 2008.
(Reporter)

Comment 4

11 years ago
Thanks.
Please include zoom-feature in next release - now that both WinSafari and IE7 as well as Opera have it! It's crucial to accessibility.

Comment 5

10 years ago
I run 3.0a8 and the cursor disappears in Google Mail and Google Docs. Furthermore, this seems related to the fact that I cannot compose new mails, only answer existing ones, because I cannot write in the main (body) text field when it is empty. When I reply to mail, the cursor is invisible in the main form.
You need to log in before you can comment on or make changes to this bug.