Crash during download leaves a ghost entry

VERIFIED DUPLICATE of bug 384810

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 384810
11 years ago
10 years ago

People

(Reporter: rstrong, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 276449 [details]
screenshot

After a crash during a download a ghost download appear when the same download is started from the same page as the previous download. None of the actions on the ghost download have any affect. After the new download completed I removed it from the list and closed the DM. When reopening the DM it was no longer displayed and starting a new download re-displayed when the same download again.

I recall something similar being present in the previous DM.

Steps:
When the app crashes during a download open the app again.
Start the download again using the exact same steps as used to start the previous download.

Actual Results:
A ghost download appeared without ability to perform actions on it.

Expected Results:
The download can either have appropriate actions performed on it.

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 384810
Verified dup
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.