Firefox 2.0.0.6 fails to identify itself correctly either to google maps or webmail.aol.com

VERIFIED INCOMPLETE

Status

()

Firefox
General
VERIFIED INCOMPLETE
11 years ago
8 years ago

People

(Reporter: Paul Redfern, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME - 08/27, URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       
Build Identifier: 2.0.0.6 (File version 1.8.1.6: 2007072518)

If I follow a link from jabber to http://aim.aol.com, I am redirected to
http://webmail.aol.com/29047/aim/en-gb/SystemRequirements.html
This tells me what browsers are supported by webmail.aol.com.

If I click on the Maps link in www.google.co.uk, I receive a similar message:
"Your web browser is not fully supported by Google Maps. More information »"
Following the "More Information" link results in 
http://local.google.co.uk/support/bin/answer.py?answer=16532&topic=1499

Reproducible: Always

Steps to Reproduce:
1. Try to open http://local.google.co.uk
or 
1. Try to open http://webmail.aol.com

Actual Results:  
http://local.google.co.uk/support/bin/answer.py?answer=16532&topic=1499
or
http://webmail.aol.com/29047/aim/en-gb/SystemRequirements.html

Expected Results:  
Browser should have identified itself successfully.

Comment 1

11 years ago
Works for me. Can you please tell us what your user-agent string is, to check if it has been modified. It's not filled in the bugreport either, so you might have a problem there. This can happen with some extensions, or mayeb you're using a special firewall or proxy-server.

To check, go to http://gemal.dk/browserspy/basic.html and report what is printed next to UserAgent . In my case (a standard US-English Firefox 2.0.0.6), it's :
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
WFM as well using Firefox 2.0.0.6 on Mac OS X and Windows Vista.

Paul, I'd also recommend trying a new profile as some extension may have altered your profile settings which could be why your UA string is wrong.

http://kb.mozillazine.org/Profile_Manager
Whiteboard: CLOSEME - 08/27
(Reporter)

Comment 3

11 years ago
Thank you both for your comments. 

To both I would say that I have upgraded continuously from Version 1 onwards (i.e., in this case, I upgraded from 2.0.0.5 to 2.0.0.6 - with no other changes to OS, proxy or firewall settings) and this is the first time that this issue has arisen, which seems to me to indicate an 'undocumented feature' with the upgrade, which is worth reporting. 

In specific response to Jo Hermans, as it happens, nothing appears in _any_ line in gemal.dk/browserspy/basic.html, (and I agree that it should). On the other hand other browsers (using the same proxy, firewall etc settings) do identify themselves correctly.

In response to Samuel Snider, I appreciate the hint, and will follow it up. But I should point out, in addition to the general comment I made at the beginning of this post, that I am not the only person to have experienced such a problem, see for example, http://groups.google.com/group/Google-Maps-Troubleshooting/ browse_thread/thread/83e90aad068ac340 .

Again, I am sure that something is broken. But I am equally convinced that it is the upgrade itself (and not 'some extension')that has broken it.
(Reporter)

Comment 4

11 years ago
Thank you both for your comments. 

To both I would say that I have upgraded continuously from Version 1 onwards (i.e., in this case, I upgraded from 2.0.0.5 to 2.0.0.6 - with no other changes to OS, proxy or firewall settings) and this is the first time that this issue has arisen, which seems to me to indicate an 'undocumented feature' with the upgrade, which is worth reporting. 

In specific response to Jo Hermans, as it happens, nothing appears in _any_ line in gemal.dk/browserspy/basic.html, (and I agree that it should). On the other hand other browsers (using the same proxy, firewall etc settings) do identify themselves correctly.

In response to Samuel Snider, I appreciate the hint, and will follow it up. But I should point out, in addition to the general comment I made at the beginning of this post, that I am not the only person to have experienced such a problem, see for example, 
http://groups.google.com/group/Google-Maps-Troubleshooting/browse_thread/thread/83e90aad068ac340 

Again, I am sure that something is broken. But I am equally convinced that it is the upgrade itself (and not 'some extension')that has broken it.

Comment 5

11 years ago
(In reply to comment #3)
> In specific response to Jo Hermans, as it happens, nothing appears in _any_
> line in gemal.dk/browserspy/basic.html, (and I agree that it should).

Something is blocking your user agent infos, that could be an extension or (as said) a proxy... since other browsers are working it's more likely an extension/profile problem. 
So first try in Safe Mode (http://kb.mozillazine.org/Safe_Mode), then if that works disable all extensions and re-enable one by one to find the cause.
If that still does not work follow Samuel suggestion to create a new profile and see if there you can solve the problem.
(Reporter)

Comment 6

11 years ago
(In reply to comment #5)

Marco,

Thank you for your comment.

I am aware that something is blocking the user_agent info, and am also aware of the debugging procedure to be followed, which (older viewers may recall) is sadly reminiscent of the bad old days of extension conflicts in Mac OS8 & 9!

Even then, I am not sure of success, as my Netscape browser, which I assume shares the same profile, does identify itself correctly.

My point, in raising this issue, is that there should never have been a problem to be solved in the first place, and that it is the upgrade that has caused it.

Comment 7

11 years ago
Could you post an image of about:config with the filter setup to "agent" string?
Could you post a list of all your extensions (you can use nightly tester tools)
Also, please notice that if you don't reply to requests (Safe mode and new profile) it will be difficult to actually find the problem.
(Reporter)

Comment 8

11 years ago
Created attachment 276612 [details]
screen-grab -in response to response 7
(Reporter)

Comment 9

11 years ago
Marco, 

Apologies for failing to understand that the procedures you and Samuel have outlined were actually requests that I should do so in order to help you with debugging. However in all the comments posted so far there has been an underlying suggestion that there is something that I must have done (other than upgrade) to have caused the problem I have reported. 

I have posted an image of my about:config 'agent' settings as you requested, and I promise that I _will_ undertake the steps you have outlined. 

However, you must also be aware of how time-consuming these are going to be and I do not think I have the time right now to undertake them. It is now getting on for 2 1/2 hours since I started responding to the comments posted, hoping to clarify the nature of the issue for correspondents, and I really must get on with my day's work (it is now 10:45 am, London time). 

Comment 10

11 years ago
It's not necessarily something that you did (like wiping out the settings in about:config). It looks to me that your HTTP-request are passing through some kind kind of proxy-server that strips away the headers. Maybe an anonymizer service ? Or maybe some kind of extension ?

Note that Netscape does not (or should not) share the same profile !
Paul, did you try Safe Mode?
http://kb.mozillazine.org/Safe_Mode
... creating a new Profile?
http://kb.mozillazine.org/Profile_Manager
also consider the suggestions in comment 10.
Paul, any luck with the suggestions in comment 10/11?
No response from Reporter.

-> INCOMPLETE
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INCOMPLETE

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.