Splitter doesn't work correctly when there's a fixed-width element between it and URL/Search bar

RESOLVED DUPLICATE of bug 391121

Status

()

Firefox
Toolbars and Customization
RESOLVED DUPLICATE of bug 391121
10 years ago
10 years ago

People

(Reporter: Stefan Breunig, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007081205 Minefield/3.0a8pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007081205 Minefield/3.0a8pre

The newly added splitter in bug 267831 makes "fixed-width" elements (e.g. buttons) shrink when put next to it. 
Given the following configuration: URL Bar, new Window button, Splitter, Search Bar.

The splitter will size the Search Bar correctly, but the URL Bar will stay the same width. Instead, the new Window button will be "flexed". See attached screenshot for clarification. 
Adding two fixed-width elements on each side will make it behave even more awkwardly. 

Reproducible: Always
(Reporter)

Comment 1

10 years ago
Created attachment 276493 [details]
Showing the problems with fixed-width elements put next to the splitter

I use a custom theme here, but it happens on the default theme as well, I checked that before.
(Reporter)

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 391121
You need to log in before you can comment on or make changes to this bug.