Compiler warning in nsNavHistory.h

RESOLVED DUPLICATE of bug 391526

Status

()

RESOLVED DUPLICATE of bug 391526
11 years ago
9 years ago

People

(Reporter: sdwilsh, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
/Developer/mozilla/toolkit/components/places/src/nsNavHistory.h: In constructor 'nsNavHistory::nsNavHistory()':
/Developer/mozilla/toolkit/components/places/src/nsNavHistory.h:576: warning: 'nsNavHistory::mAutoCompleteOnlyTyped' will be initialized after
/Developer/mozilla/toolkit/components/places/src/nsNavHistory.h:575: warning:   'PRInt32 nsNavHistory::mExpireDays'
/Developer/mozilla/toolkit/components/places/src/nsNavHistory.cpp:239: warning:   when initialized here
I think josh and/or mano has a patch for this warning.

Comment 2

11 years ago
bug 391526
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 391526
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.