bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Flash doesn't work on some sites.

VERIFIED FIXED

Status

Camino Graveyard
Plug-ins
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: Markus S., Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.9a8pre) Gecko/2007081300 Camino/2.0a1pre (like Firefox/3.0a8pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.9a8pre) Gecko/2007081300 Camino/2.0a1pre (like Firefox/3.0a8pre)

A few sites claim that Camino is not Flash capable eventhough the Flash plugin is installed.

Reproducible: Always

Steps to Reproduce:
1. Visit http://www.looki.de/video/metroid_prime_3_corruption_neuer_trailer_video_1158.html
2. Visit http://www.khronos.org/library/detail/siggraph_2007_opengl_birds_of_a_feather_bof_presentation/

Actual Results:  
Not loading any Flash file.

Comment 1

11 years ago
Both sites WFM in the 8/1 trunk build.
- In what way, exactly, do they not work?
- What version of Flash do you have?
- Is this a recent trunk regression?
- Do they work in Firefox for you?

(In the future, please don't comment in tracker bugs about bugs that haven't been confirmed yet.)
Severity: major → normal
Summary: Flash is only working on certain sites → Flash doesn't work on some sites.
(Reporter)

Comment 2

11 years ago
Created attachment 276559 [details]
How it looks

> Both sites WFM in the 8/1 trunk build.

Both sites also work in the Camino August 06 trunk build.


> - In what way, exactly, do they not work?

See screenshot.


> - What version of Flash do you have?

According to about:plugins I have 9.0r60.


> - Is this a recent trunk regression?

Yupp. Happend sometime during the last week.


> - Do they work in Firefox for you?

Yes, they work. If they didn't work, I hadn't file a Camino bug, but rather a Core or whatever bug.
Safari's also working.
9.0r47 is the current Flash Player version.

Comment 4

11 years ago
They still WFM after upgrading to 8/13 trunk, and I'm also using Flash 9.0r60 (the beta release of the version with Quartz drawing support).

Can you find a specific regression date, and also see if you can reproduce it with a clean profile?

Comment 5

11 years ago
I've got the 2007081201 (2.0a1pre) build failing, the 2007081100 (2.0a1pre) build working here.
10.4.10 PPC; KAMiKAZOW is also on PPC.
Flash Player 9.0r60
tested with TroubleShoot Camino.

Weird thing: on the looki.de site, the right-hand sidebar contains a flash movie the works - and worse: it is not blocked by Flashblock.

That could point to some JS issue used to load the flash movie in the main part of the page.

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-08-11+00%3A00%3A00&maxdate=2007-08-12+01%3A00%3A00&cvsroot=%2Fcvsroot

hmm

Comment 6

11 years ago
I strongly suspect that the issue is caused by Flashblock. It doesn't matter if it is turned ON or OFF.
As a test, I took the flashblock.jar I have in my Minefield profile (latest version, 1.5.4.1) and put it in my Camino build (contents > chrome).
Restarted the browser, checked both the pages linked above and a couple of sites where I just had noticed that flash stuff was not blocked (e.g. http://talkingpointsmemo.com/archives/016521.php for a simple page). 
With the latest flashblock.jar all those worked correctly (Flash is blocked and when unblocked, plays correctly). Testing with Flashblock disabled, both URLs listed above also play correctly.

Bug 391973 !

Comment 7

11 years ago
Reporter: can you confirm that installing the latest Flashblock.jar fixes the problem for you? (See the bug Philippe mentions for details.) If it does, I think it's safe to mark this as a dupe.

cl
(Reporter)

Comment 8

11 years ago
No, but I found a weird pattern.
Camino sometimes shows the Flash file. I found that sometimes the result can be changed if I visit another site, empty the cache and visit
http://www.khronos.org/library/detail/siggraph_2007_opengl_birds_of_a_feather_bof_presentation/
again.

It behaves the same with new and old flashblock.jar file.

Comment 9

11 years ago
This is puzzling indeed, and I could reproduce *after* I updated to the most recent nightly (and copied the new flashblock.jar in that new build).
When I then went to fetch the flashblock.jar out of my Minefield profile and replaced the one in Camino, all start working again.
(Reporter)

Comment 10

11 years ago
Do we use the same FlashBlock version? I tried the one that I extracted from http://downloads.mozdev.org/flashblock/flashblock-1.5.4.1.xpi as posted in Bug 391973.
And -- as I said -- this didn't result in any change of behaviour.

I btw found also out that when Camino is in "Too old for Flash" mode, Camino also doesn't display any results from Google Image Search.

Comment 11

11 years ago
(In reply to comment #10)
> Do we use the same FlashBlock version? I tried the one that I extracted from
> http://downloads.mozdev.org/flashblock/flashblock-1.5.4.1.xpi as posted in Bug
> 391973.

Yes.

> And -- as I said -- this didn't result in any change of behaviour.
Well I get a 'sometimes change in behaviour'. Something like you comment 8.

> 
> I btw found also out that when Camino is in "Too old for Flash" mode, Camino
> also doesn't display any results from Google Image Search.
> 
Something is seriously broken. Do you get the same regression range for that Google problem (see comment 5)?

(Reporter)

Comment 12

11 years ago
Well, I went back to the August 6 build, and the Google Image problem didn't occur to me yet.
You sespected a JS related problem in comment 5 and I think as well that this is the problem, because Google Image results are also plcaed via JS.

Comment 13

11 years ago
This works now, using build 2007081520 (2.0a1pre). Default Flashblock.jar.
Movies load/are blocked/...
The patch in bug 392305 solved this.

KAMiKAZOW , does the Google Image works as well on your side with the next nightly build  ? (If not: file a separate bug, please).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

11 years ago
I didn't experience this bug in recent days. Thanks.
v. FIXED by virtue of bug 392305.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.