Downloading files should be appended with an extension to differentiate them from fully-completed downloads.

RESOLVED DUPLICATE of bug 288152

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 288152
11 years ago
10 years ago

People

(Reporter: stevee, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a8pre) Gecko/2007081305 Minefield/3.0a8pre ID:2007081305

Currently when download a zip file from http://hourly-archive.localgho.st/ the file gets downloaded to the directory of my choice, but using the full filename, eg: 20070813_1419_firefox-3.0a8pre.en-US.win32.zip

This is bad enough because anyone watching their download dir will see what looks like a usable file and perhaps try and run/move the file.

But further, when we have cross-session resumable downloads, then i guess any files we are downloading when we quit firefox will also have a normal looking filename with a normal extension. In this case, anyone trying to run the file will get an error, and it will be hard to differentiate between files that are genuinely completed, and those which are still in the middle of being downloaded.

So I really think we need to add a file-extension on the end of all currently-being-downloaded files, like .part or .!fx or some such.

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 288152
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.