If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Choosing "work offline" in the profile chooser at startup has no effect

RESOLVED FIXED

Status

SeaMonkey
Startup & Profiles
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Nelson Bolyard (seldom reads bugmail), Assigned: neil@parkwaycc.co.uk)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.06 KB, patch
Scott MacGregor
: review+
Benjamin Smedberg
: review+
Details | Diff | Splinter Review
Gecko/200708100202 SeaMonkey/2.0a1pre

I have several profiles.  When I start SM, I get the Profile Chooser dialog.
That dialog contains two checkboxes, the first of which is "work offline".
Checking this box has no effect.  The browser starts online, and is able to 
fetch any URL.  

Reproducible: 100%
Flags: blocking-seamonkey2.0a1?
(Reporter)

Comment 1

10 years ago
Should this have been filed against the "profile manager" component?
I don't know if "profile chooser" is part of "profile manager" or not.
(Reporter)

Updated

10 years ago
Assignee: general → nobody
Component: General → Profile: Manager
QA Contact: general → profile-manager
(Assignee)

Comment 2

10 years ago
So, what happened with the old profile chooser was that when you forced the app offline in the profile manager it disabled the automatic offline management.

The toolkit profile manager doesn't do this, so the offlineStartup component thinks that the app is offline due to automatic offline management. It then overrides this as necessary according to your preferences.

If this is correct then the bug is in toolkit, and should affect Thunderbird.
(Assignee)

Comment 3

10 years ago
Created attachment 276769 [details] [diff] [review]
Proposed patch

I don't think this should break Thunderbird; if anything it should fix it!
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #276769 - Flags: review?(mscott)
Attachment #276769 - Flags: review?(bienvenu)

Comment 4

10 years ago
Comment on attachment 276769 [details] [diff] [review]
Proposed patch

looks good to me, but you'll also want a review from bsmedberg since it's a toolkit change.
Attachment #276769 - Flags: review?(mscott) → review+
(Assignee)

Updated

10 years ago
Attachment #276769 - Flags: review?(bienvenu) → review?(benjamin)

Updated

10 years ago
Attachment #276769 - Flags: review?(benjamin) → review+
(Assignee)

Comment 5

10 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Flags: blocking-seamonkey2.0a1?
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.