Last Comment Bug 392183 - Extensions still in "updated" rss feed during new update are not recognized as new feed item
: Extensions still in "updated" rss feed during new update are not recognized a...
Status: RESOLVED FIXED
:
Product: addons.mozilla.org Graveyard
Classification: Graveyard
Component: Public Pages (show other bugs)
: 3.0
: All All
: -- normal
: ---
Assigned To: Fred Wenzel [:wenzel]
:
Mentors:
https://addons.mozilla.org/en-US/thun...
: 411834 (view as bug list)
Depends on: 375535
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-14 06:39 PDT by Sebastian Hengst [:aryx][:archaeopteryx]
Modified: 2016-02-04 14:51 PST (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Use version permalink in RSS to distinguish updated feed items (2.92 KB, patch)
2007-12-12 03:27 PST, Fred Wenzel [:wenzel]
no flags Details | Diff | Splinter Review

Description Sebastian Hengst [:aryx][:archaeopteryx] 2007-08-14 06:39:21 PDT
ThunderBrowse extension is in development and gets updated often. There is a item for the last update in the feed, but it doesn't get recognized as new by Thunderbird.

Use <guid>...</guid> to solve the problem, I guess.
Comment 1 Fred Wenzel [:wenzel] 2007-08-22 07:00:39 PDT
True. Any idea on what guid would be useful there?
Comment 2 Sebastian Hengst [:aryx][:archaeopteryx] 2007-08-23 01:22:38 PDT
<add-on id>-<date and time stamp>?
Comment 3 Mike Shaver (:shaver -- probably not reading bugmail closely) 2007-08-23 06:37:57 PDT
sprintf("%s-%s-%d", addOnGUID, addOnVersion, versionId) ?
Comment 4 Fred Wenzel [:wenzel] 2007-08-23 07:59:15 PDT
Ah, yeah, the latter sounds like it could work pretty well. I'll see if I can write a patch.
Comment 5 Fred Wenzel [:wenzel] 2007-08-23 11:56:01 PDT
http://cyber.law.harvard.edu/rss/rss.html#ltguidgtSubelementOfLtitemgt

says the GUID can be a permalink. So I wonder if we should link to something along the lines of:
https://addons.mozilla.org/en-US/firefox/addons/versions/1865#installTrigger7551

... which would in turn make this bug depend on bug 375535?
Comment 6 Fred Wenzel [:wenzel] 2007-12-12 03:27:21 PST
Created attachment 292746 [details] [diff] [review]
Use version permalink in RSS to distinguish updated feed items

Pending review on attachment 292744 [details] [diff] [review], this patch will use the new permalink anchor in order to give each feed item a permalink as GUID.

Note that this also includes the RSS timestamp fix for bug 375525 (i.e. this bug will fix both issues).
Comment 7 Fred Wenzel [:wenzel] 2007-12-31 05:55:13 PST
This has been committed to the 3.2 redesign branch as r9312 and merged into trunk as r9313. Marking fixed, needs push. Thanks, all.
Comment 8 Fred Wenzel [:wenzel] 2008-01-11 01:16:20 PST
*** Bug 411834 has been marked as a duplicate of this bug. ***
Comment 9 Fred Wenzel [:wenzel] 2008-01-11 02:03:18 PST
Hm. Though this has been pushed (and it's fixed for the URL above), other feeds (see bug 411834) don't provide a GUID yet. Reopening.
Comment 10 Fred Wenzel [:wenzel] 2008-01-12 10:02:10 PST
Okay I added a GUID for the categories RSS feed too, SVN r9577. I also fixed the GUID on the "all versions" page, r9579. Push needed.
Comment 11 Justin Scott [:fligtar] 2008-02-14 16:34:38 PST
This is live.

Note You need to log in before you can comment on or make changes to this bug.