Mozilla gets "NNTP-error No Such Article" when trying to open certain articles.

VERIFIED DUPLICATE of bug 35739

Status

MailNews Core
Networking: NNTP
P3
normal
VERIFIED DUPLICATE of bug 35739
18 years ago
9 years ago

People

(Reporter: carljohan, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({regression})

Trunk
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (X11; U; Linux 2.2.14 i686)
BuildID:    2000041811

When using Mozilla to read news, one persons posts were unreadable.
The nntp-server responded "430 No Such Article\r\n" even though
the article is on the server. Netscape 4.7 could read it so I
used ethereal to find out what Mozilla was trying to fetch.

Netscape 4.7 fetches articles by the article number but
Mozilla fetches them by the Message-ID header in the
post.

When using Netscape to fetch one of the persons post the
Message-ID of it was:
<1ead2vv.m0dewzx1mdbN%d98dan+news@dtek.chalmers.se>

When Mozilla tries to fecth the same article it tries
to fetch the article with the Message-ID:
<1ead2vv.m0bdewzx1mdbN\3318dan+news@dtek.chalmers.se>

Notice how the "%d9" has changed to the octal character
\331 (Hex 0xd9). So Mozilla tries to get the wrong article,
hence the NNTP-error

The Message-Id is correctly stored in the .msf for the
group.

It is just this guys posts, and all his posts, that can't be
read.

Reproducible: Always
Steps to Reproduce:
1. Log on to news.dd.chalmers.se (only people from Chalmers University
   can do this)
2. Open the group cth.dtek.general .
3. Try to open a post from Dan Karlsson d98dan+news@dtek.chalmers.se

Actual Results:  Mozilla responds: "NNTP error No Such Article"

Expected Results:  Mozilla should show the article.
crap.  this has happened a couple of times in the past.

I wonder if the url parsing code has changed again?

I'll investigate.
adding andreas to the cc list, this might be url parsing related.

Comment 3

18 years ago
Url parsing code has not changed recently, however some charset encoding before
urlparsing has changed. Move to UTF8, using unicode, ... I would start the
search there.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: regression
Target Milestone: --- → M16
thanks for the info, andreas.  I'll debug and see what's going on.

adding regression to the keyword, since message id's like that used to work.

carljohan@kjellander.com, which version of mozilla are you using?
(Reporter)

Comment 5

18 years ago
I'm using Mozilla M15 BuildID 2000041811 (the one from mozilla.org) with
PSM 1.1.
this is fixed in m16.  please test with m16 and let me know if you still have a
problem.

(FYI:  official m16 builds have not been made yet.)


*** This bug has been marked as a duplicate of 35739 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Updated

18 years ago
QA Contact: lchiang → huang

Comment 7

18 years ago
Verified as duplicate.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

18 years ago
I've tried the latest M16 build and now it fetches
post by the article number instead of the Message-ID
so the problem is gone.

Hope the translation of "%d9" to 0xd9 hex doesn't
cause trouble elsewere.
try this, in a recent build:

open a browser window
type in that article url (news://host/message-id) in the location bar.

does it display the article in the browser window?
(Reporter)

Comment 10

18 years ago
Nope! I checked with build 2000052420 and it still tries
to fetch the wrong article according to ethereal.
The %d9 gets translated to the hex 0xd9.

If you change the % to %25 (ascii '%') it tries to
get the correct article. But what is the syntax
for selecting the correct group?
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.