[Linux] Since bug 388517 had landed, new mail notification window is blank and does not close.

RESOLVED DUPLICATE of bug 392305

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED DUPLICATE of bug 392305
10 years ago
10 years ago

People

(Reporter: Frederic Bezies, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a8pre) Gecko/2007081415 Firefox/3.0a8pre
Build Identifier: 

It is very simple to reproduce. Send yourself 2 or 3 mails.

Get them. A blank pop-up mail notification window appears.

I got these errors in ErrorConsole :

Error: folderSummaryInfoEl.parseFolder is not a function
Source File: chrome://messenger/content/newmailalert.js
Line: 88

and 

Error: parseFloat is not defined
Source File: chrome://messenger/content/newmailalert.js
Line: 189

Last working trunk build : 11 august 2007 => 2007-08-13-11-trunk
First broken trunk build : 12 august 2007 => 2007-08-12-03-trunk

Reproducible: Always

Steps to Reproduce:
1.See details
2.
3.
Actual Results:  
blank notification window

Expected Results:  
notification window with info.

Using official trunk build or homemade trunk build : same result :(
(Reporter)

Comment 1

10 years ago
Created attachment 276731 [details]
screenshot showing the problem

I have to kill thunderbird in task manager to let the notification window go.
Would you like to try again with the build id for the last working build? 2007-08-13-11 seems unlikely to be what you meant.

Comment 3

10 years ago
Hmm, I'm struggling to see how the new download manager changes could be ineracting with the linux new mail notification alert. 

This one error in your console, I find particularly troubling:

Error: parseFloat is not defined

why would parseFloat not be defined?
For what little it's worth, alerts WFM in a Linux build from an hour or so ago.
(Reporter)

Comment 5

10 years ago
Phil : I mean 2007-08-11-13-trunk

Sorry for wrong typing.

I will try this the latest build I can find from there :

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/tinderbox-builds/tb-linux-tbox-trunk/

thunderbird-3.0a1pre.en-US.linux-i686.tar.bz2  15-Aug-2007 00:23  9.3M  

And I will try to see what's happening.
(Reporter)

Comment 6

10 years ago
Sigh !

Still same visual bug and same error in error console :

Error: parseFloat is not defined
Source File: chrome://messenger/content/newmailalert.js
Line: 189

I tried removing *.mfasl file, and nothing new.

Stinks like my profile is rotten or what ?!
works now so I'll blame bug 392305 (I found the summary of bug 391885 kinda more poetic though)
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392305
You need to log in before you can comment on or make changes to this bug.