bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

I cannot download anything from Mozilla, including saving pictures.

VERIFIED WORKSFORME

Status

()

Toolkit
Downloads API
--
major
VERIFIED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Caitie George, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

Whenever I try to save a file from Mozilla, whether it's a music file or a picture or an email attachment, I cannot save the file. The Download Manager doesn't pop up and if I click it on from the "Tools" folder, the entire window is blank. It's been happening for awhile and I've tried to uninstall and reinstall several times and nothing's worked so far. 

Reproducible: Always

Steps to Reproduce:
1.Closed the current window.
2.Restarted program and tried to save again.
3.Uninstalled and reinstalled Mozilla several times.
Actual Results:  
Nothing has happened. I still cannot save ANY documents, files, or pictures from Mozilla. 

Expected Results:  
I should be able to save my files to my computer. 

I can't think of anything else to add. I've tried uninstalling tool bars and un-needed plug-ins, but nothing's worked so far.
The problem is in your profile folder where your personal settings are so reinstalling Firefox won't help.
Please clean up your download manager and if this doesn't work, try deleting the file downloads.rdf in your profile folder.
http://kb.mozillazine.org/Downloads.rdf
Actually, if you haven't already deleted it--and wouldn't mind it being seen by folks who test/fix Download Manager bugs, could you please attach (or email me privately, if you prefer) your downloads.rdf file?
OK; I can reproduce with Firefox 2.0.0.6 on Windows Vista with the downloads.rdf Caitie sent me; nothing appears in the Download Manager window, and I can't download anything.  (That's the bad news.)

The good news is that when dropped into a trunk profile for Minefield (Firefox 3 in development), we convert it to downloads.sqlite and all is well.

Caitie, I'd suggest deleting downloads.rdf if you don't care about it; it'll be automatically regenerated.  You shouldn't have this problem in Firefox 3, sorry!
Caitie, because there are only security/small polish fixes planned for a possible 2.0.0.7 release, we won't be fixing this in that major version of 2.0 (it would likely require larger changes); sorry that you have a real bug we didn't catch in the 2.x release.

Marking worksforme only because this is fine in the in-development version of Firefox 3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

11 years ago
How come uninstalling it and then reinstalling it isn't working then? I primarily use my laptop, but the Firefox on my desktop (which has been upgraded to the version on my laptop) works with the downloads just fine and saving pictures. Does it have something to do with my laptop?
(In reply to comment #5)
> How come uninstalling it and then reinstalling it isn't working then? I
> primarily use my laptop, but the Firefox on my desktop (which has been upgraded
> to the version on my laptop) works with the downloads just fine and saving
> pictures. Does it have something to do with my laptop

downloads.rdf is in your profile directory, and we leave profile-specific files intact when installing and uninstalling Firefox/Thunderbird.

If you delete downloads.rdf you should be fine; it'll auto-regenerate! 

(Reporter)

Comment 7

11 years ago
Thank you! That worked perfectly!
np; glad I could help :-)
Status: RESOLVED → VERIFIED

Comment 9

11 years ago
Guys, I tried to find "downloads.rdf" file in my computer and My Firefox 2.0.06 doesn't have one.  I have the same problem with saving anything at all: pictures, programs etc. 

Please advise.  I also tried to reinstall firefox couple of times, and nithing helps.

Daniel
It is in a folder which is hidden by default. If you don't want to change your Windows settings in Folder Options, here is a description how to find your profile: http://kb.mozillazine.org/Profile_Folder
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.