File / Save Page As... xml empty-element end slash disappiers from <meta .. />

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Mikko Korpela, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

page meta elements end slash disappiers when saving page <meta .. /> => <meta .. >
IMHO this means that the result is not valid xml
Don't know if it does it with other empty elements too.

Reproducible: Always

Steps to Reproduce:
Test page:
<html>
<head>
   <meta http-equiv="something" content="and something"/>
</head>	
<body>Foo</body>
</html>

1. Load page in firefox
2. Save Page As...
3. Open the result file
Actual Results:  
<html>
<head>
   <meta http-equiv="something" content="and something">
</head>
<body>Foo</body>
</html>

Expected Results:  
<html>
<head>
   <meta http-equiv="something" content="and something"/>
</head>
<body>Foo</body>
</html>

Comment 1

10 years ago
I can't reproduce this bug.

I think the actual problem could've been your understanding. Giving Mozilla a XHTML file doesn't mean it's treated as XML. If XHTML is sent as text/html, it was treated as HTML and saved that way.
If I send XHTML with the correct media type application/xhtml+xml, then Mozilla treats it as XML and saves it correctly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.