HTML using 4 cols with equal width=25%, first col is too narrow

RESOLVED INVALID

Status

()

Firefox
General
--
trivial
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: Howard Cary Morris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Congoo NetPass; InfoPath.1; .NET CLR 2.0.50727; FDM; .NET CLR 3.0.04506.30)
Build Identifier: 7.0.5730.11

used following code
<table width='100%' >
<col>
<colgroup><Col width="25%"><Col width="25%"><Col width="25%"><Col width="25%">
</colgroup> 
First column much narrower than other 3, entire HTML copied below
<html>
<head>
<title>Howard’s Favorites</title>
</head>

<body>

<div align=center>

<h1><a
href="mailto:Howard%20%3cHoward_Cary_Morris@hotmail.com)%3e?subject=About%20Favorites">Howard</a>’s
Favorites</h1>

<div align=left>
<h2>Category </h2>

<h3>Location or sub category</h3>

<table width='100%' >
<col>
<colgroup><Col width="25%"><Col width="25%"><Col width="25%"><Col width="25%">
</colgroup> 
<tr  valign=top>
  <td>

<h3>Games</h3><ul>

	<li><a href="http://www.thegamershack.com/">Cribbage</a>

	<li><em>Cases</em><ul>

		<li><a href="http://www.igl.net/teamcrib/">Old

		<li><a href="http://igl.net/teamgscrib/">New </a>
	 	</ul>


	<li><a href="http://www.gamehouse.com/onlinegames/">Gamehouse</a>
	</ul>
  <td>

<h3>News</h3><ul>

	<li><a href="http://www.jpost.com/">Jerusalem Post </a>

	<li><a href="http://www.nytimes.com/">New York Times </a>

	<li><a href="http://jta.org/">JTA </a>

	<li><a href="http://www.cnn.com/">CNN</a>

	<li><a href="http://www.theAtlantic.com/">Atlantic</a>

	<li><a href="http://www.france24.com/france24Public/en/news/world.html">France Public TV</a>
	</ul>
  <td>

<h3>Math</h3><ul>

	<li><a href="http://mathworld.wolfram.com/">Math World </a>
	</ul>
  <td>

<h3>Email</h3><ul>
	<li><a href="http://hotmail.com/">Hotmail </a>
	<li><a href="https://swmail.southwest.tn.edu/exchange/">STCC</ul>
</table>

</body>
</html>


Reproducible: Always

Steps to Reproduce:
1. Made this HTML my private home page
2. Started Firefox
3. May or may not make font larger
Actual Results:  
First column of table is narrrower than other 3

Expected Results:  
All four columns of table should have same length

Valign=top does not make a difference
Did not check of following made a diference:
<h3> in table cell
<ul> and imbedded <ul> in table cell - only first column had imbedded <ul>
Well a good start would be to make your html validate with http://validator.w3.org/ because atm it looks like it's all over the place and there's many tags you don't even bother to close.
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> Well a good start would be to make your html validate with
> http://validator.w3.org/ because atm it looks like it's all over the place and
> there's many tags you don't even bother to close.

That seemed to fix the problem - thank you
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Resolution: FIXED → INVALID
no probs!
You need to log in before you can comment on or make changes to this bug.