OnMsgParsed event never fires when loading imap messages

RESOLVED FIXED

Status

Thunderbird
General
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Scott MacGregor, Assigned: Scott MacGregor)

Tracking

({regression})

x86
Windows Vista
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
I think my imap channel / url ownership overhaul broke this.

http://mxr.mozilla.org/seamonkey/source/mailnews/base/src/nsMsgStatusFeedback.cpp#170

when an on stop notification fires on the document, we get the imap channel, get the url from the channel and use the hdr sink associated with the url to notify the front end that the message is done being loaded.

But after my changes it looks like the url we get from the channel is null.

This prevents the phishing detection code from running since that fires after the document has been loaded.
(Assignee)

Comment 1

11 years ago
Created attachment 276896 [details] [diff] [review]
possible fix

I was being overly aggressive and clearing the channel's reference to the url when the channel gets closed. But the close method is called before the STATE_STOP notification fires from the doc loader.  

But I need to re-run the memory leak tests to make sure this doesn't re-introduce the leak.
Assignee: nobody → mscott
Status: NEW → ASSIGNED
(Assignee)

Comment 2

11 years ago
Comment on attachment 276896 [details] [diff] [review]
possible fix

I've run a bunch of leak scenarios involving displaying imap messages and so far I'm not seeing any new leaks introduced by this change.
Attachment #276896 - Flags: superreview?(bienvenu)

Comment 3

11 years ago
Comment on attachment 276896 [details] [diff] [review]
possible fix

I wonder if we're going to see more thread-safety assertions? :-)
Attachment #276896 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Updated

11 years ago
Blocks: 381992
(Assignee)

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.