Closed Bug 392427 Opened 14 years ago Closed 12 years ago

Bookmarks "yellow star" is subtle when the address bar is also yellow

Categories

(Firefox :: Theme, defect, P4)

defect

Tracking

()

VERIFIED INVALID

People

(Reporter: jruderman, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

If I bookmark an https page by clicking on the star, the star's interior turns from light yellow to more yellow.  I think this change is too subtle.  One way to fix this problem would be to make the interior of the "non-bookmarked" "empty" star white rather than transparent.
Yeah, this was a mistake.  Mano: here is a white star non-bookmarked star: https://bugzilla.mozilla.org/attachment.cgi?id=277191
Checking in browser/themes/pinstripe/browser/places/starPage.png;
/cvsroot/mozilla/browser/themes/pinstripe/browser/places/starPage.png,v  <--  starPage.png
new revision: 1.2; previous revision: 1.1
done
Checking in browser/themes/winstripe/browser/places/starPage.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/starPage.png,v  <--  starPage.png
new revision: 1.2; previous revision: 1.1
done
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 M8
verified with - Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a8pre) Gecko/2007091304 Minefield/3.0a8pre

no longer seems like an issue as the star has a "button" background which sets it apart from the https location bar yellow
Status: RESOLVED → VERIFIED
Can attachment 277191 [details] be checked in again? For beta 3, even?
Status: VERIFIED → REOPENED
Flags: blocking-firefox3?
OS: Mac OS X → Windows XP
Resolution: FIXED → ---
Target Milestone: Firefox 3 alpha8 → ---
Keywords: regression
Seems like this was regressed by bug 413806 for Windows, bug 413471 for Linux, and bug 397723 for Mac. I guess we'll need new non-transparent icons for all three platforms? We could just land the placeholder for now, as Dao suggests. 
Priority: -- → P1
Target Milestone: --- → Firefox 3 beta3
OS: Windows XP → All
Hardware: PC → All
I'm only going to land it on winstripe for now. I'm sure the Tango team can get a fixed icon very quickly, and maybe the pinstripe team can, too. If we run out of time, we can land the placeholder icon on all three platforms, but it definitely would look ugly, as the icons are different on all three platforms.
Checking in browser/themes/winstripe/browser/places/starPage.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/starPage.png,v  <--  starPage.png
new revision: 1.4; previous revision: 1.3
done
(Note that schrep gave approval for the re-landing of the icon for Beta 3 in bug 392682, where the icon is located.)
Here's a new unselected star with some tweakings too make it less evident. Using a white star is a no go imho since it will look more evident then the golden one on dark backgrounds.
Doesn't block beta 3, but we'll likely accept checkins on replacement images up until we cut the tree for building.
Flags: blocking-firefox3? → blocking-firefox3+
Priority: P1 → P2
Target Milestone: Firefox 3 beta3 → Firefox 3 beta4
Attachment #301249 - Flags: ui-review?(beltzner)
Attachment #301249 - Flags: approval1.9b3?
Comment on attachment 301249 [details]
Package with the new unselected star in png and svg

uir+a=beltzner
Attachment #301249 - Flags: ui-review?(beltzner)
Attachment #301249 - Flags: ui-review+
Attachment #301249 - Flags: approval1.9b3?
Attachment #301249 - Flags: approval1.9b3+
Checking in browser/themes/gnomestripe/browser/places/starPage.png;
/cvsroot/mozilla/browser/themes/gnomestripe/browser/places/starPage.png,v  <--  starPage.png
new revision: 1.4; previous revision: 1.3
done
>I'm only going to land it on winstripe for now. I'm sure the Tango team can get
>a fixed icon very quickly, and maybe the pinstripe team can, too.

Note that this isn't an issue for pinstripe, since it is using an outline star and a filled in star to denote bookmarked vs. un-bookmarked.
(In reply to comment #13)

> Note that this isn't an issue for pinstripe, since it is using an outline star
> and a filled in star to denote bookmarked vs. un-bookmarked.

It *could* become an issue on the Mac, if they choose to address Bug 414868 – The grey bookmarking star in proto is confusing.
Duplicate of this bug: 417159
Priority: P2 → P3
Note that this issue might go away based on the result of bug 417844
Target Milestone: Firefox 3 beta4 → Firefox 3
Priority: P3 → P4
Not blocking on this bug for final ship. Would take a safe enough patch if one comes through.
Flags: wanted-firefox3+
Flags: blocking-firefox3-
Flags: blocking-firefox3+
Target Milestone: Firefox 3 → ---
Is this still an issue now that the yellow background for SSL sites has been removed from the location bar?
Status: REOPENED → RESOLVED
Closed: 14 years ago12 years ago
Depends on: 417844
Resolution: --- → INVALID
Component: Places → Theme
QA Contact: places → theme
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.