All users were logged out of Bugzilla on October 13th, 2018

Enabling Javascript crashes Firefox

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: bugs, Unassigned)

Tracking

({crash})

2.0 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

Javascript has suddenly started crashing Firefox. It seems that some pages that use JS are OK, but iGoogle and GMail are not.

Reproducible: Always

Steps to Reproduce:
1. Create clean account with -p flag
2. Disable Javascript
3. Go to gmail.com and sign in
4. Enable JS
5. Click switch to standard view or whatever it says at the top

Actual Results:  
Firefox crashes to desktop

Expected Results:  
Pretty AJAX page rendered

I would build a debug version but I only have VS2005 which apparently will not work. However by debugging in VS2005 on the release version it tells me: Unhandled exception at 0x00000000 in firefox.exe: 0xC0000005: Access violation writing location 0x0709e8f0.
(Reporter)

Comment 1

11 years ago
Created attachment 277063 [details]
Talkback crash dump

It seems by the way that the error reported in VS2005 changes. This time I got: Unhandled exception at 0x00000000 in firefox.exe: 0xC0000005: Access violation reading location 0x0000014c.
Can you provide the talkback id, like TB28659753Z (http://kb.mozillazine.org/Talkback)  from the crash ?
Keywords: crash
Version: unspecified → 2.0 Branch

Comment 3

11 years ago
that address isn't useful, see:
http://developer.mozilla.org/en/docs/Using_the_Mozilla_symbol_server

w/ that you can use your debugger and our symbols for the binary we shipped.
(Reporter)

Comment 4

11 years ago
Hmm, it turns out I had only been sleeping my computer while this was happening. With a reboot, I can no longer reproduce this crash. The developer in me is unsatisfied, but the user in me is happy. :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.