java plugin : regression with firefox 3.0 alpha 7 : java error message

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Matp75, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7) Gecko/2007080210 GranParadiso/3.0a7

the mentionned page (see url) works fine with Firefox 2.0.0.6
With Gran Paradiso alpha 7, the page is ok except where there should be a youtube video. Firefox is not crashing or stalled. it seems java is called at this time and there is a error. I don't know if the problem source is something with the new firefox or an error in the applet but it's a regression between two firefox versions with the same plugin version. (I updated to the latest jre and the behaviour is the same)

Reproducible: Always

Steps to Reproduce:
1. Launch Gran Paradiso alpha 7
2. Goes to the bug'url
3. try to see the video
Actual Results:  
the video is missing (it's grey instead)

Expected Results:  
image of a youtube video

right clicking for the java console, I have these error messages :
Java Plug-in 1.6.0_02
Utilisation de la version JRE 1.6.0_02 Java HotSpot(TM) Client VM
Répertoire d'accueil de l'utilisateur = C:\Documents and Settings\mar


----------------------------------------------------
c:   effacer la fenêtre de la console
f:   finaliser les objets de la file d'attente de finalisation
g:   libérer la mémoire
h:   afficher ce message d'aide
l:   vider la liste des chargeurs de classes
m:   imprimer le relevé d'utilisation de la mémoire
o:   déclencher la consignation
p:   recharger la configuration du proxy
q:   masquer la console
r:   recharger la configuration des politiques
s:   vider les propriétés système et déploiement
t:   vider la liste des threads
v:   vider la pile des threads
x:   effacer le cache de chargeurs de classes
0-5: fixer le niveau de traçage à <n>
----------------------------------------------------

Paramètre CODE manquant dans une étiquette APPLET.
Paramètre CODE manquant dans une étiquette APPLET.
java.lang.NullPointerException: name
	at sun.applet.AppletClassLoader.getResourceAsStream(Unknown Source)
	at sun.applet.AppletPanel$7.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at sun.applet.AppletPanel.createApplet(Unknown Source)
	at sun.plugin.AppletViewer.createApplet(Unknown Source)
	at sun.applet.AppletPanel.runLoader(Unknown Source)
	at sun.applet.AppletPanel.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
java.lang.NullPointerException: name
	at sun.applet.AppletClassLoader.getResourceAsStream(Unknown Source)
	at sun.applet.AppletPanel$7.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at sun.applet.AppletPanel.createApplet(Unknown Source)
	at sun.plugin.AppletViewer.createApplet(Unknown Source)
	at sun.applet.AppletPanel.runLoader(Unknown Source)
	at sun.applet.AppletPanel.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
(Reporter)

Updated

11 years ago
Keywords: regression
Version: unspecified → Trunk

Updated

11 years ago
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins

Comment 1

11 years ago
Java? The video there is using the Flash plugin.
(Reporter)

Comment 2

11 years ago
Yes, looks like the wrong plugin is launched.

the code which calls one of the video is this one :

<embed width="400" height="325" src="http://www.youtube.com/v/yS2zPjf44mQ" allowfullscreen="true"></embed>

I can go directly to the youtube url with firefox 3 and it works.(in a new tab)

There are other flash (advertisement) on the same page, which works.

It just doesn't work when embedded in the whole page.

(Reporter)

Comment 3

11 years ago
works now with gran paradiso alpha 8 (with url or the local page saved at the time)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.