Theme confused after updating to 1.1.4

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: Rob Janssen, Unassigned)

Tracking

SeaMonkey 1.1 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: bugday0420)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); nl-NL; rv:1.8.1.6) Gecko/20070802 SeaMonkey/1.1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl-NL; rv:1.8.1.6) Gecko/20070802 SeaMonkey/1.1.4

We updated Seamonkey from 1.1.2 to 1.1.4
We have lots of users, each of them with their own profile.
After the update we got a few reports that the program takes very long to start and then the layout of the buttons is very messed up.  Mail can be navigated but the mail view pane remains a blue area instead of the mail.
After ananalyzing, it appears that all of the users that had this problem were using the classic theme.  But not all users of the classic theme had this problem!

When opening the preferences dialog for theme setting, none of the two themes (classic or modern) is selected and no preview is shown.  When a theme is selected here and the app is restarted, it works OK again.

Reproducible: Sometimes



Expected Results:  
Existing settings carried over during update from 1.1.2 to 1.1.4

Those profiles are often quite old, and have been used with various versions of Mozilla before.  Without this problem.
Creating a new profile of course solves it too (this was our first quick-fix solution), but loses all the user's preferences.
(Reporter)

Comment 1

11 years ago
I have done more debugging and testing and it looks like the file chrome.rdf in the profile has some inconsistent content, and this has become a problem as of version 1.1.4

I have generated new chrome.rdf files for classic and modern theme selection, copied those over the existing files in the profiles depending on their content, and the problem no longer appears when the user logs in.

However, I still do not understand the real cause of the sudden problem.
Can you reproduce with SeaMonkey v1.1.9 ?

Could attach the initial/1.1.2 file and the broken/1.1.4 and the corrected/1.1.4 files ?
(= give some more details)
Version: unspecified → SeaMonkey 1.1 Branch
(Reporter)

Comment 3

10 years ago
It has not happened again...
(In reply to comment #3)
> It has not happened again...

Marking WFM for you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Whiteboard: bugday0420
You need to log in before you can comment on or make changes to this bug.