If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unable to "edit as new" .EML files attached in an e-mail

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
major
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: David, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: 2.0.0.6

Unable to edit as new EML files attached in an e-mail with version 2 of Thunderbird.  If I recieve an email or open an e-mail file with Thunderbird Version 1.5.x.x, I could use the edit as new option and everything worked fine to resend the e-mail as if it were the original, but now in version 2 I cannot.  In version 1.5.x.x, all I needed to do is save the eml file on my computer, open it and edit it as new (Ctrl+E).

Now in version 2, it appears a message saying that there was an error opening the message editor window (Note that I do not have the exact message since I downgraded to version 1.5 of thunderbird as soon as I got this message because I use this option very often).

It would be fun to not be obliged to save the eml file to your computer to edit it as new even though it worked in version 1.5.x.x, it would save a step to correct first of all that bug and also to not have to save the file to disk to edit it as new.

Reproducible: Always

Steps to Reproduce:
1. Send yourself an email containing an EML file attched in it.
2. Once e-mail recieved, open attahced EML file and Edit as new or use (Ctrl+E)
   (You can also try to save the file on your computer, open it with Thunderbird and edit it as new and the same message will appear.)
Actual Results:  
A message appears saying an error occured when creating the message compose window.

Expected Results:  
A new window should appear permitting you to edit the message as if your were sending a new message using the contents in the eml file.  To know exactly what it should do, use Thunderbird 1.5.0.12 (The one I use) and you will see the expected results since it worked in that version and stopped working in version 2.

Worked with version 1.5.0.12 of thunderbird but not version 2.0.0.6 and below.
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0

Comment 1

10 years ago
Yep, in the error console I get

Error: server is not defined
Source File: chrome://messenger/content/mailCommands.js
Line: 150

->NEW (bug 366482 may possibly be related)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Unable to "edit as new" EML files attached in an e-mail (Version 2.0.0.x to 2.0.0.6 only) → Unable to "edit as new" .EML files attached in an e-mail (Version 2.0.0.x to 2.0.0.6 only)

Updated

10 years ago
OS: Windows XP → All
Hardware: PC → All

Updated

10 years ago
Summary: Unable to "edit as new" .EML files attached in an e-mail (Version 2.0.0.x to 2.0.0.6 only) → Unable to "edit as new" .EML files attached in an e-mail

Updated

10 years ago
Duplicate of this bug: 396722

Comment 3

10 years ago
This is the same error I get, but I'm not opening attached emails, just regular email .eml files.

I can open a message in my sent folder (or any folder), Ctrl-S to save it as a file, open the file (which generates a Thunderbird email window as usual), and then hit Ctrl-E to Edit Message as New.

Thunderbird opens an error window with:

An error occurred while creating a message compose window. Please try again.

I can try again and again, but I get the exact same result every time.  Editing messages as new, modifying something, and then sending it again is a REALLY useful feature.
Blocks: 269826
Duplicate of this bug: 418412

Comment 5

8 years ago
Bug still manifests in 2.0.0.21, but WFM with Shredder (I'm running an 0801 nightly).  Probably fixed with bug 366482.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.