websurveyor.net (Vovici) - rejects non-Firefox Gecko browsers

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
11 years ago
2 years ago

People

(Reporter: david, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-us] [serversniff] [contactready], URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070802 SeaMonkey/1.1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070802 SeaMonkey/1.1.4

I went to the indicated URL and got the following:  

"Unsupported Browser
This product requires Internet Explorer 6.0 SP1 or later, or Firefox 1.5 or later."

When I spoofed Firefox 2, I was able to view the page.  The spoof used the following UA string:  
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Reproducible: Always




This bug might be included in bug #334967.

Comment 1

11 years ago
Yep, this happens in Camino too. Spoofing as Firefox 1.5 or Firefox 2 fixes the problem.
Blocks: 334967
OS: Windows XP → All
Hardware: PC → All
Summary: [websurveyor.net] Bad Sniffer Rejects SeaMonkey but Accepts Firefox → [websurveyor.net] - rejects non-Firefox Gecko browsers
Summary: [websurveyor.net] - rejects non-Firefox Gecko browsers → websurveyor.net - rejects non-Firefox Gecko browsers

Comment 2

11 years ago
David, did you ever contact anyone at that site and point them to

http://geckoisgecko.org/ ?

cl
(Reporter)

Comment 3

11 years ago
I just now sent an E-mail to Vovici, the company that owns Websurveyor.  I included the following links: 
  <http://geckoisgecko.org/>
  <http://wiki.mozilla.org/User:Sardisson/Gecko_is_Gecko>
  <http://developer.mozilla.org/en/docs/Browser_Detection_and_Cross_Browser_Support>

I also included a link to this bug report.  

By the way, spoofing with the UA string "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9, NOT Firefox/2.0.0.13" does not work.  I had to spoof with "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080313 Firefox/2.0.0.13".  
(Reporter)

Comment 4

11 years ago
I sent a message to <support@vovici.com> on 21 April.  Vovici apparently owns WebSurveyor.  

Vovici just now replied.  The reply indicates that they will consider the problem only if I have an account with them.  I must logon to that account to report any problems.  

I called Vovici's toll-free number for support.  They claim this is something that each outside survey developer must handle, although the surveys are operated from Vovici's own servers.  However, they also gave me another E-mail address to contact.  I'll try again.  
Summary: websurveyor.net - rejects non-Firefox Gecko browsers → websurveyor.net (Vovici) - rejects non-Firefox Gecko browsers
(Reporter)

Comment 5

10 years ago
Still a problem.  

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.21) Gecko/20090403 SeaMonkey/1.1.16

Comment 6

8 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 7

8 years ago
This is still a problem.  Going to the cited URI, I get the message: 

Unsupported Browser (Mozilla1.9.1.16 Mozilla 1.9.1.16 WinXP)
This product requires Internet Explorer 6.0 SP1 or later, or Firefox 1.5 or later. 

I am using SeaMonkey 2.0.11.
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
(Reporter)

Comment 8

7 years ago
Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20120604 SeaMonkey/2.10

Nothing has changed.  This is still a problem.

Comment 9

4 years ago
→ http --follow --print hH http://www.websurveyor.net/ 'user-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.21) Gecko/20090403 SeaMonkey/1.1.16'
GET /error/UnsupportedBrowser.aspx HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate
Cookie: ASPSESSIONIDQSTASBST=MLJJFCMCMJGDFKFMCCHIBJIN; ASP.NET_SessionId=1se3maz3at4d1p55znzjzwjv
Host: desktop.websurveyor.net
user-agent:  Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.21) Gecko/20090403 SeaMonkey/1.1.16

HTTP/1.1 200 OK
Cache-Control: private
Content-Length: 1162
Content-Type: text/html; charset=utf-8
Date: Wed, 03 Sep 2014 06:40:52 GMT
Server: Microsoft-IIS/6.0
X-AspNet-Version: 2.0.50727
X-UA-Compatible: IE=EmulateIE7


Still UA sniffing going on for unknown browsers.
Same for Firefox on Android, and Firefox OS, Chrome Mobile, IE10 Mobile, Safari iPad

The message is 
> Unsupported Browser (Mozilla30 Mozilla 30.0 Unknown)
> This product requires Internet Explorer 6.0 SP1 or later, or Firefox 1.5 or later. 

They have a contact us page
http://www.verint.com/about/doing-business-with-verint/verint-offices-worldwide/index.html
please contact Customer Support at vovicisupport@verint.com.


Given the no support across the browsers, I have low expectations. I would propose to switch it as WONTFIX. Not worth our time.
Assignee: english-us → nobody
Status: REOPENED → NEW
Component: English US → Desktop
Whiteboard: [country-us] [serversniff] [contactready]
(Reporter)

Comment 10

4 years ago
Having encountered this problem again within the past month, I request that this bug report remain open.  Closing it as WontFix does not make the problem go away.
Hi David, would you like to help getting in contact with the site owners, since you're able to reproduce?
(Reporter)

Comment 12

4 years ago
(In reply to Mike Taylor ~*:miketaylr*~ from comment #11)
> Hi David, would you like to help getting in contact with the site owners,
> since you're able to reproduce?

I contacted them twice already.  The response indicates they will only fix their problem if contacted by a customer, which would be a business that uses their survey system.  

I do not remember who requested the most recent survey.  Thus, I will wait until the next time I have a problem.  Then, I will contact whatever business requested the survey.  Among other things, I will inform that business that whatever they paid Vovici for survey services was wasted money.
So fwiw, 
When going to http://desktop.websurveyor.net/login.aspx?ReturnUrl=%2fDefault.aspx

>  Don't have an account yet?
> Learn more about our products! 

The link opens a new tab to
http://www.verint.com/services/enterprise-workforce-optimization/educational-services/index/index.aspx

which gives a 500 - Internal server error.

Going back to the root.
The address is now 
http://www.verint.com/services/enterprise-workforce-optimization/educational-services/index

Where I do not see vovici being advertised at all.

I see in http://www.verint.com/splash/vovicis-name-is-changing
> When Vovici® was acquired by Verint® Systems in July 2011, the combination 
> of our companies resulted in the market’s most comprehensive Voice of the 
> Customer solution available today, with proven, award-winning capabilities 
> for enterprise feedback management, speech analytics, and text analytics.

The fact that this Web site has not changed branding is for me a clear indication that it is not really maintained anymore, more than security or anything else.
Also in 
http://www.verint.com/solutions/enterprise-workforce-optimization/support/enterprise-feedback-management-global-support/index

> Welcome to the Customer Support page for Verint Enterprise Feedback Management
> (including legacy Vovici solutions). Please consult the table below to reach 
> the appropriate support contact for your region.

**legacy**

when you click on this, you get to 
http://s3.parature.com/ics/support/default.asp?deptID=5474
Which doesn't block UA.

I still think it is a WONTFIX. :)
Let's close as WONTFIX given comment #13. If someone can still reproduce the issue at some point in the future, we can re-open and go from there.
Status: NEW → RESOLVED
Last Resolved: 8 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.