"ASSERTION: QueryInterface needed", nsURIChecker missing nsIRequestObserver in QI map

RESOLVED FIXED

Status

()

Core
Networking
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Ben Turner (not reading bugmail, use the needinfo flag!), Assigned: Ben Turner (not reading bugmail, use the needinfo flag!))

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Created attachment 277151 [details] [diff] [review]
Patch

Seems that NS_NewRequestObserverProxy isn't properly QI'ing its result. Patch attached.
Attachment #277151 - Flags: superreview?(cbiesinger)
Attachment #277151 - Flags: review?(cbiesinger)
Comment on attachment 277151 [details] [diff] [review]
Patch

The problem is deeper than I thought. New patch in a sec.
Attachment #277151 - Attachment is obsolete: true
Attachment #277151 - Flags: superreview?(cbiesinger)
Attachment #277151 - Flags: review?(cbiesinger)
Created attachment 277309 [details] [diff] [review]
Patch

Ok, looks like nsIRequestObserver wasn't in the QI map.
Assignee: nobody → bent.mozilla
Status: NEW → ASSIGNED
Attachment #277309 - Flags: superreview?(cbiesinger)
Attachment #277309 - Flags: review?(cbiesinger)
Comment on attachment 277309 [details] [diff] [review]
Patch

oh, good catch!
Attachment #277309 - Flags: superreview?(cbiesinger)
Attachment #277309 - Flags: superreview+
Attachment #277309 - Flags: review?(cbiesinger)
Attachment #277309 - Flags: review+
Attachment #277309 - Flags: approval1.9?
Summary: "ASSERTION: QueryInterface needed" in nsRequestObserverProxy → "ASSERTION: QueryInterface needed", nsURIChecker missing nsIRequestObserver in QI map
Comment on attachment 277309 [details] [diff] [review]
Patch

a=bzbarsky
Attachment #277309 - Flags: approval1.9? → approval1.9+
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.