If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Allow different tabs to have different (login) cookies from the same web site (per-tab cookies)

VERIFIED DUPLICATE of bug 351414

Status

Camino Graveyard
Tabbed Browsing
--
enhancement
VERIFIED DUPLICATE of bug 351414
10 years ago
10 years ago

People

(Reporter: Sebastian, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.4) Gecko/20070509 Camino/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.4) Gecko/20070509 Camino/1.5

I use several different google accounts, and different wikis on the same server. Logging in to one google account logs me out of the other. I can work around this by running lots of different browsers at the same time, but there are only so many browsers I can have open at once.

Wouldn't it be cool if I could be logged in to one google account in one tab, and to another one in another?

There may be some usability issues, e.g. how to keep track of the fact that I logged out of gmail in one tab but not in another... or avoiding having to log in again and again and again to the same web site in the course of a day just because I closed the tab that had the relevant cookie. But there's no reason why Opera can have one cookie file and Camino another, but Camino can't have two. Correct?

Perhaps the files could be per-window rather than per-tab, the windows have unique names, and the cookie manager has an option to make an existing cookie per-window oder valid for all windows.

Reproducible: Always

Steps to Reproduce:
N/A

Comment 1

10 years ago
Even if Gecko supported this, the UI would be way too complicated; this is beyond the scope of something we would include in Camino.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX

Comment 2

10 years ago
Actually, this is a dupe of an existing WONTFIX bug; changing resolution.
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 351414

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.