AUS should offer complete update if no partial mar is available

RESOLVED DUPLICATE of bug 511967

Status

P3
normal
RESOLVED DUPLICATE of bug 511967
11 years ago
5 years ago

People

(Reporter: steffen.wilberg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Right now there are no partial updates (partial.*.mar) available for windows (bug 392579), but there are complete updates (complete.mar). AUS should offer the complete update in that case because I hate having to download and install nightlies manually.
Target Milestone: 4.x (triaged) → 3.0
I think you guys are off the hook for this one, it's the glob of ick that generates the nightly updates at fault here. It grabs the snippets from /opt/aus2/build/, transmogrifies them, and the pushes back into the live part of AUS. If it fails to generate a partial then it just bombs out (woo!) and AUS never finds out about the complete it could be offering. Bug 392579 was about the initial failure to publish a complete snippet, which has the same result.

See also bug 404768 and brain@rhelmer for similar plans to do away with the nightly updates generator and do it all in tinderbox.

Assignee: morgamic → nobody
Component: General → Build & Release
Priority: -- → P3
Product: AUS → mozilla.org
QA Contact: general → build
Target Milestone: 3.0 → ---
Version: 2.0 → other
(In reply to comment #1)\
> See also bug 404768 and brain@rhelmer for similar plans to do away with the
> nightly updates generator and do it all in tinderbox.

s/brain@rhelmer/bug 410806/ ? :)

Seriously though, brain@rhelmer says the stuff in this bug should be AUS' job, the build machines should just have to register what they've uploaded and what branch it was on (should be able to do this kind of thing with AUS3).
Component: Build & Release → Release Engineering: Projects
QA Contact: build → release
Found in triage - happens rarely, but still seems worth doing.
Mass move of bugs from Release Engineering:Future -> Release Engineering. See
http://coop.deadsquid.com/2010/02/kiss-the-future-goodbye/ for more details.
Component: Release Engineering: Future → Release Engineering
This should be fixed as a side-effect of bug 511967.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 511967
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.