Get rid of non-macro implementations of |QueryInterface|

RESOLVED WONTFIX

Status

()

P3
normal
RESOLVED WONTFIX
19 years ago
16 years ago

People

(Reporter: Joerg.Brunsmann, Assigned: alecf)

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

19 years ago
Bug # 23737 aims at implementing |QueryInterface| with a single table-driven
implementation. In order get a step closer to this table-driver approach,
one must make sure that every component implements |QueryInterface| with
a macro defined in 

http://lxr.mozilla.org/seamonkey/source/xpcom/base/nsISupportsUtils.h

This bug is an attempt to collect patches which eliminates non-macro
implementations of |QueryInterface|

Comment 1

19 years ago
Scott, you want to be owner of this. Help will be greatly appreciated.
Assignee: dp → scc
(Reporter)

Comment 2

19 years ago
Created attachment 8725 [details] [diff] [review]
First patch for mozilla/editor

Comment 3

19 years ago
Whats this scc-obsolete anyway.
Assignee: scc-obsolete → scc
(Reporter)

Comment 4

19 years ago
Created attachment 8869 [details] [diff] [review]
Small patch for mozilla/db
(Reporter)

Comment 5

19 years ago
Created attachment 8936 [details] [diff] [review]
Patch for mozilla/dom
(Reporter)

Comment 6

19 years ago
Trying to change the cc-mail address to scc@mozilla.org

How do you expect a table driven |QueryInterface| for something like this

http://lxr.mozilla.org/seamonkey/source/netwerk/cache/mgr/nsCachedNetData.cpp#142

How do you expect a table driven |AggregatedQueryInterface|?

How do you expect a table driven |QueryInterface| if the implementor has
additional program logic in |QueryInterface| like:

http://lxr.mozilla.org/seamonkey/source/layout/html/content/src/nsHTMLFormElement.cpp#212

(Click on the NS_IMPL_HTML_CONTENT_QUERY_INTERFACE macro and then on the 
NS_IMPL_CONTENT_QUERY_INTERFACE macro to see the additional logic)

Comment 7

19 years ago
setting status to NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M20

Updated

18 years ago
QA Contact: leger → kandrot

Comment 8

16 years ago
alecf: you've been looking into this (as per bug #23737), so perhaps you want to
own this bug?
Assignee: scc → alecf
Status: ASSIGNED → NEW
(Assignee)

Comment 9

16 years ago
I think most of the cases we can change have long since been fixed. I'm marking
this WONTFIX
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.