Passed testcases in a partial run show "not run" on return.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
11 years ago
2 years ago

People

(Reporter: stephend, Assigned: coop)

Tracking

Trunk
x86
Windows Vista

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Summary: Passed testcases' radio buttons in a partial run show "not run" on return.

Steps to Reproduce:

1. Log in to Litmus.
2. Do a partial run of a testrun, passing a few of the testcases, at least.
3. Submit the run.
4. Return to the run--noting that it's marked correctly with the percentage run--and look at the testcases that you've passed.

Actual Results:

The testcases backgrounds show up in green, and they have a green checkmark icon, indicating that they've passed.  However, their radio buttons are "not run".

Expected Results:

The radio buttons should be selected as "pass"
(Reporter)

Comment 1

11 years ago
Created attachment 277266 [details]
Screenshot
(Reporter)

Comment 2

11 years ago
<zach> stephend: here's the thing though
<zach> if we mark the tests as "pass" that you passed before
<zach> and you then submit the page 
<zach> you'll have run some tests twice
<stephend> hmm
<zach> and get duplicate results
<stephend> well, it can be marked invalid
<stephend> or wontfix, I don't mind :-)
<zach> unless we keep track of the duplicates, which is kind of silly since we don't know whether you meant them to be duplicates or not 
<zach> hmm
<zach> I'll think about it
(Assignee)

Comment 3

11 years ago
"Not run" is simply the default selection. As Zach pointed out, the green background + checkmark doesn't indicate the actual status (pass/fail/unclear) of the previously submitted result, it is meant to try to discourage the filing of duplicate results. 

There's no explicit reason why we allow duplicates other than that it is easier to manage, and changing it now would require more effort.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.