crash if enter a long string into the search bar and switch program

RESOLVED WORKSFORME

Status

()

Toolkit
Find Toolbar
--
critical
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: John Smith, Unassigned)

Tracking

({crash, stackwanted})

1.8 Branch
x86
Windows XP
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-06-05)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

Firefox crash if I enter a very long string into the search bar and switch to another program.

Reproducible: Always

Steps to Reproduce:
1.Type a long string into the search bar (about 100,000 characters)
2.Click anywhere in the window
3.Switch to another program
Actual Results:  
A message box with something like "Firefox is trying to read the memory at location 0x00000000..." and keep appearing. Disappear when I chose to debug it

Expected Results:  
Nothing, or limit the search bar text length

Theme: default
Windows: XP SP2, patched everything
Memory: 256MB
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Comment 1

9 years ago
John, can you reproduce this with version 3, and supply a crash report id so we get the stack?
Severity: normal → critical
Keywords: crash, stackwanted
Whiteboard: closeme 2009-06-05
Version: unspecified → 1.8 Branch
(Reporter)

Comment 2

9 years ago
I'm unable to reproduce this on 3.0.10 myself. Looks like you have one less bug :)

Comment 3

9 years ago
=> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.