Closed Bug 392774 Opened 13 years ago Closed 11 years ago

mailnews use received date don't work (IMAP)

Categories

(Thunderbird :: Preferences, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 402594

People

(Reporter: lzlrftmu, Unassigned)

References

Details

Attachments

(1 file)

16.46 KB, application/octet-stream
Details
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; hu; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: 3.0a1pre (2007081804)

flag mailnews.use_received_date don't work.

please test it with future and past date.


Reproducible: Always

Steps to Reproduce:
1. mailnews.use_received_date;true
2. 
3.
Version: unspecified → Trunk
(In reply to comment #0)
> flag mailnews.use_received_date don't work.

Did you execute "Rebuild Index" after change to mailnews.use_received_date=true?
no, but is this needed at new mails?
so this worked in older releases but don't work in current!
WORKSFORME with Thunderbitd trunk 2007/8/04 build and 2007/8/20 build(Win-XP).
 (1) Seamonkey 
     Compose a mail, Send Later,
     Edit "Unsent Message" file by text editor and change 2007 to 2017 in Date:,
     "Rebuild Index" for Unsent folder(date displayed as 2017),
     Send Unsent Messages
 (2) Thunderbird (mailnews.use_received_date=true)
     Get Msgs => date column display was 2017
No problem also in "Rebuild index" after modification of Date: / Received: headers in a local mail folder.  

(0) Go Tools/Options/Advanced/General/Config Editor, and check
    value of mailnews.use_received_date
(1) Create a local mail folder, and copy the mail of future or past date to the
    mail folder, and "Rebuild Index"
What is displayed in Date column?
What is difference between your Thunderbird's behavior and your expectation?
Correction. sorry for spam.
Get Msgs => date column display was hh:mm only (today=2007 in Received: header) 
mailnews.use_received_date true
:|mail -a 'Date: Sun, 25 Aug 2008 11:11:00 +0200' root

the displayed date is: 2008.08.25. 11:11
new mails don't need rebuild index but i'm tried... nothing happening.

version 3.0a1pre (2007081804)

connection: imap
(In reply to comment #6)
> connection: imap

Sorry but I don't know IMAP case well...
Received: header may be excluded from header request list when FETCH for arrived new mail.
Can you get IMAP protocol log when new mail download?   
  http://kb.mozillazine.org/Session_logging_for_mail/news
  http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
  Attach log file(text/plain if size is accepted) to bug. Never paste, please.

> :|mail -a 'Date: Sun, 25 Aug 2008 11:11:00 +0200' root
> the displayed date is: 2008.08.25. 11:11

Question to rule out different problem/phenomenon.
Date displayed where?
Date column of thread pane?
Or Date: field in mail header box in mail pane(mail review pane)?

Due to Bug 392413?
> Bug 392413 OnMsgParsed event never fires when loading imap messages
do you need any additional information?
(In reply to comment #9)
> do you need any additional information?

No need of addtional information.
Answers to questions in comment #7 and data I requested by comment #7 are sufficient for initial problem analysis.   
Attached file imap log
(1) First FETCH doesn't request Received: header.
> SendData: 8 UID fetch 12627 (UID RFC822.SIZE FLAGS BODY.PEEK[HEADER.FIELDS
>  (From To Cc Subject Date Message-ID Priority X-Priority References Newsgroups In-Reply-To Content-Type)])
(2) And Received: headers are downloaded with all other headers by following FETCH. 
> SendData: 9 UID fetch 12627 (UID RFC822.SIZE BODY.PEEK[])

If ".msf" entry is created after (1) before (2), there is no chance to get timestamp in Received: header...

> Date: Sun, 28 Aug 2008 11:11:00 +0200
> Received: from localhost (localhost [127.0.0.1])
>  by localhost (8.13.8/8.13.8/Debian-3) with ESMTP id l7Q8vYgC013760
>  for <root@localhost>; Sun, 26 Aug 2007 10:57:34 +0200

Will "Re-build Index" changes date column display for the mail?

> so this worked in older releases but don't work in current!

What trunk build worked?

FYI.
Change for "Received column" support has been started in Bug 166254, so behavior of trunk may vary daily. Please be careful in testing.
Will mail.server.serverXX.fetch_by_chunks=false alter flow and phenomenon?
(Read Bug 92111, and see Bug 92111 Comment #45 for this setting)
Please test with build used for getting log. 
> Will "Re-build Index" changes date column display for the mail?

don't work. version 3.0a1pre (2007082504)

> What trunk build worked?

that was 3.0a too, but i can't tell the build number.
(In reply to comment #14)
> > Will "Re-build Index" changes date column display for the mail?
> don't work. version 3.0a1pre (2007082504)
Similar issue to Bug 184490 is involved?
Blocks: 402594, 423952
Summary: mailnews use received date don't work → mailnews use received date don't work (IMAP)
Duplicate of this bug: 423952
No longer blocks: 402594
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 402594
You need to log in before you can comment on or make changes to this bug.