Obsolete instructions in template variables.none.tmpl concerning bug_re.

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
User Interface
--
trivial
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Terry Mackintosh, Assigned: Denis Roy)

Tracking

Bugzilla 3.0
Bug Flags:
approval +
approval3.0 +

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20050130
Build Identifier: Bugzilla 3.0

In the file variables.none.tmpl is the following notice, but this notice is no lonter needed or correct as this functionality is now already built in.

  # Note on changing terms:
  # Changing this will not affect "linkification" of your new terms.
  # This means if you change "bug" to "problem", then if you have
  # "problem 3" in a comment, it won't become a clickable URL.
  # To have that feature, you must edit the quoteUrls function in
  # Bugzilla/Template.pm.
  # Change the line:
  # my $bug_re = qr/bug\s*\#?\s*(\d+)/i;
  # to something like:
  # my $bug_re = qr/(?:bug|problem)\s*\#?\s*(\d+)/i;
  # (here "problem" was used instead of bug - substitute as needed!).
 

Reproducible: Always

Steps to Reproduce:
1. Read the above file.
2. Read the file the note indicates needs fixing.
3. Note a fix already is there.
Actual Results:  
I did a test post and indeed it works, my alias for bug was linked.

Expected Results:  
Just what it did.

Comment 1

10 years ago
quoteUrls() has been fixed in bug 223880. Do you want to attach a patch which removes this obsolete comment?
Status: UNCONFIRMED → NEW
Depends on: 223880
Ever confirmed: true
Target Milestone: --- → Bugzilla 3.0
Version: unspecified → 3.0

Updated

10 years ago
Duplicate of this bug: 415862

Updated

10 years ago
Duplicate of this bug: 415973
(Assignee)

Comment 4

10 years ago
(In reply to comment #1)
> quoteUrls() has been fixed in bug 223880. Do you want to attach a patch which
> removes this obsolete comment?

I put a patch in dup bug 415973 (sigh -- I swear I looked for a dup first) that rewords the comment on how to *avoid* this behaviour. We have users who are familiar with 'bug' as a linkification term and were lost when they started using another bugzilla-based app which used different terms, so this info could still be useful.

Updated

10 years ago
Assignee: installation → ui
Component: Installation & Upgrading → User Interface
(Assignee)

Comment 5

10 years ago
Created attachment 301725 [details] [diff] [review]
Patch with comment removed altogether

(In reply to comment #1)
> quoteUrls() has been fixed in bug 223880. Do you want to attach a patch which
> removes this obsolete comment?

Here you go ... I still think the comment has some value, though, but it's your call.

Updated

10 years ago
Attachment #301725 - Flags: review+

Updated

10 years ago
Assignee: ui → webmaster
Flags: approval3.0+
Flags: approval+

Comment 6

10 years ago
tip:

Checking in template/en/default/global/variables.none.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/variables.none.tmpl,v  <--  variables.none.tmpl
new revision: 1.7; previous revision: 1.6
done

3.0.3:

Checking in template/en/default/global/variables.none.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/variables.none.tmpl,v  <--  variables.none.tmpl
new revision: 1.4.2.1; previous revision: 1.4
done
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.