Crash at a forum input tekstfield - 2nd time same forum. [@ nsTextInputListener::EditAction]

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
11 years ago
7 years ago

People

(Reporter: Erik den Houter, Unassigned)

Tracking

({crash})

2.0 Branch
x86
Windows 98
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; nl; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Win98; nl; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

Repeated error: sircumstances exact copy of TB35007213Y but Talkback coul'd not send.

Now, at the 20th character i entered in a textfield at a forum a complete crash.
about four tabs open. In the second hour after boot.
The last days i spend up to 14 hours at the same forum without major problems.
No Talkback report, although Talkback was there i think, also NU 2000 crashguard came up, but the crash was to severe, and i did my very best to recover the report(s), but no luck.
The textfield was open for about ten seconds when this happend, about the same time as the first time this happend, on 16-08 where i HAD a Talkback report:
TB35007213Y
So this from today is a copy of the crash from that report, but this time the system failed to recover.

Note: i am not 100% sure, but i even much think that the Norton Crashguard spoke of a crash of Talkback.EXE. My screen was very corrupted, so i was distracted.

URL where this happend:
http://forum.computeridee.nl/showthread.php?p=337597#post337597


Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.
2.
3.



Not crashed.
Dupe of/related to bug 339975 and/or bug 355104?
Component: Tabbed Browser → General
Keywords: crash
QA Contact: tabbed.browser → general
Summary: Crash at a forum input tekstfield - 2nd time same forum. → Crash at a forum input tekstfield - 2nd time same forum. [@ nsTextInputListener::EditAction]
Version: unspecified → 2.0 Branch
Incident ID: 35007213
Stack Signature	nsTextInputListener::EditAction ebc0fa34
Product ID	Firefox2
Build ID	2007072518
Trigger Time	2007-08-16 12:21:27.0
Platform	Win32
Operating System	Windows 98 4.10 build 67766446
Module	FIREFOX.EXE + (0021c8dd)
URL visited	http://forum.computeridee.nl/showthread.php?p=336807#post336807
User Comments	In a forum at about the sixth character i typed in a reply-box.
Since Last Crash	341013 sec
Total Uptime	341013 sec
Trigger Reason	Access violation
Source File, Line No.	c:/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/layout/forms/nsTextControlFrame.cpp, line 459
Stack Trace 	
nsTextInputListener::EditAction  [mozilla/layout/forms/nsTextControlFrame.cpp, line 459]
nsEditor::NotifyEditorObservers  [mozilla/editor/libeditor/base/nsEditor.cpp, line 1927]
nsAutoPlaceHolderBatch::~nsAutoPlaceHolderBatch  [mozilla/editor/libeditor/base/nsEditorUtils.h, line 66]
nsPlaintextEditor::HandleKeyPress  [mozilla/editor/libeditor/text/nsPlaintextEditor.cpp, line 382]
nsTextEditorKeyListener::KeyPress  [mozilla/editor/libeditor/text/nsEditorEventListeners.cpp, line 250]
DispatchToInterface  [mozilla/content/events/src/nsEventListenerManager.cpp, line 144]
nsEventListenerManager::HandleEvent  [mozilla/content/events/src/nsEventListenerManager.cpp, line 1752]
nsGenericElement::HandleDOMEvent  [mozilla/content/base/src/nsGenericElement.cpp, line 2234]
nsHTMLTextAreaElement::HandleDOMEvent  [mozilla/content/html/content/src/nsHTMLTextAreaElement.cpp, line 650]
PresShell::HandleEventInternal  [mozilla/layout/base/nsPresShell.cpp, line 6485]
PresShell::HandleEvent  [mozilla/layout/base/nsPresShell.cpp, line 6268]
nsViewManager::HandleEvent  [mozilla/view/src/nsViewManager.cpp, line 2521]
nsViewManager::DispatchEvent  [mozilla/view/src/nsViewManager.cpp, line 2253]
HandleEvent  [mozilla/view/src/nsView.cpp, line 174]
nsWindow::DispatchEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 1319]
nsWindow::DispatchKeyEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 3639]
nsWindow::OnChar  [mozilla/widget/src/windows/nsWindow.cpp, line 3906]
nsWindow::OnKeyDown  [mozilla/widget/src/windows/nsWindow.cpp, line 3732]
nsWindow::ProcessMessage  [mozilla/widget/src/windows/nsWindow.cpp, line 4777]
nsWindow::WindowProc  [mozilla/widget/src/windows/nsWindow.cpp, line 1507]
KERNEL32.DLL + 0x363b (0xbff7363b)
KERNEL32.DLL + 0x24407 (0xbff94407)
0x00d88abe
(Reporter)

Comment 3

11 years ago
Dupe of/related to bug 339975:
Can't see a direct relation. For me thers was NO copy/paste action.

Dupe of/related to bug 355104?
Defenetely in both my crashes i started to enter characters at the moment the tekstbox appeared, so the page was probably NOT fully loaded.
But about typing blanks, no, although sometimes NO characters appear.
(Reporter)

Comment 4

11 years ago
Add:

I must say, two mayor setbacks i experience while using these textboxes:
a) very often my cursor dissappears, even after clicking it somewhere it doesn't return.
b)one in 20 characters is not recorded.

Comment 5

11 years ago
(In reply to comment #4)
> Add:
> 
> I must say, two mayor setbacks i experience while using these textboxes:
> a) very often my cursor dissappears, even after clicking it somewhere it
> doesn't return.
> b)one in 20 characters is not recorded.

If you've got bugs I can reproduce, CC me, I can test on Win98. I can't reproduce this one, as I don#t have a password and don't want to spam the forum by testing.
Could it be you are scarce on RAM? I am, and it shows on reading threaded forums in lots of tabs. As I'm on a slow connection, ISDN, I also disabled link prefetching. (network.prefetch-next)

If you want to see what is going on I recommend starting Process Explorer from Sysinternal.com, always delivering better tools than MS for free, so MS bought them. 

http://www.sysinternals.com redirects to
http://www.microsoft.com/technet/sysinternals/default.mspx
http://www.microsoft.com/technet/sysinternals/ProcessesAndThreads/ProcessExplorer.mspx

Firefox 2 is the last version supported for Win98.

(Reporter)

Comment 6

11 years ago
Thanks for replying.
I must say for me it is always difficult to grasp what the way of communicating is here, and everytime i want to ask i got the idear that i am the only one that doesn't know, and i am almost spamming the site with tea-talk. I will try to answere you at best:

I am not sure about what to do when you ask "CC me".
I also don't have more "bugs" than i have shown here, i think (and hope dearly)

Testing in that forum is indeed problematic this way, but i myself will pay more attention about the surcomstances these two "artifacts" show.
Logging-in would be the only thing i guess, for you could use a textbox without sending, so spamming will not be the case.
About the other text-boxes on that page, i must say that entering my usersname always goes well, i haven't made an error ever i think, but the asterixed password seems wrong once every ten times, for i get the error of "you've entered a wrong username/password, please try again". Since the username is visable, and the password not, i came to the conclusion that only the password-box errors...

Memory, well, 288 Mb, and thats for AV, firewall, TB, and FireFox. The max. tabs i use is about 8, and most of the time when i pass that number I close some, and if i did that five times i close down FF, and start again, performing a FREERAM before restart.
This way, i don't think memory amount is involved.
Very sometimes i need to start Photoshop Elements 2 too. I will pay attention for this, memory wise.
Connection: ADSL varying from 75Kbit/s to 4.5 Mbit/s.

And about Process Explorer:
I have used this program, but after every 15-30 minutes it crashes clean, and this way i have no benefit of the program. I have reported this (with crashreport) to Sysinternals, but until now with no effect (i was not alone in this).
Still have the Dependency Walker though.
(Reporter)

Comment 7

11 years ago
24-08 Third time: TB35244531W
Probably again page not fully loaded when starting to type,
Just one tab open, only flipping a few pages after boot.
Memory ? not loaded fully at all.

Comment 8

10 years ago
I have same problem :( . I can make it any time I want. I only need to press Java-button that opens textfield and type <space> as not first caracter (ex. 'a' 'space' or 'ab' 'space' or ...).
Firefox 2.0.0.11 in SAVEMODE after Windows reinstalled and updated (up to 11 dec 2007). only this page is open and fully loaded...
FireFox was installed from 2.0.0.11 version setup file.

Comment 9

9 years ago
This bug was reported using a version of Firefox that security and stability updates are no longer provided for.  All users are strongly encouraged to upgrade to Firefox 3 by selecting 'Check for Updates' in the Help menu or by going to http://www.mozilla.com/en-US/firefox/firefox.html

If you can no longer reproduce this bug using the latest Firefox 3.0.x version, please change the status of this bug to 'RESOLVED' 'WORKSFORME'.

If you can still reproduce this bug, please provide additional details to help resolve this issue.
(Reporter)

Comment 10

9 years ago
I am sorry, unfortunately I am not able to confirm.

I am not able to test FF 3 on the Windows 98SE system where the problem occurred, for the fact that i moved on to an Intel C2D system with XP Prof.

Erik den Houter.
So this does not happen on your new system? Then WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsTextInputListener::EditAction]
You need to log in before you can comment on or make changes to this bug.