Camino 1.5.1 won't load login pages

RESOLVED WORKSFORME

Status

Camino Graveyard
General
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: tocahan@yahoo.com, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

I installed Camino 1.5.1 and when I tried to login to last.fm, the login page failed to load. I click on the link, the status bar indicates that it's loading, but the login page fails to appear. This happened with Yahoo Mail, ipage (https://ipage.ingrambook.com/ipage/li001.jsp) and with Bugzilla when I tried to sign up for an account to report the problem. I re-installed 1.5 and the problem went away. On ipage, last.fm and Yahoo mail, I have login names & passwords saved to the keychain. I am running 10.4.10 on a G5 iMac.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
That's odd, since the only change to the keychain code between 1.5 and 1.5.1 was exceedingly minor.

Please download and run <http://escapedthoughts.com/camino/CaminoDiagnostics.zip>, and attach the file it creates using the "Add an attachment" link above.

Comment 2

11 years ago
Oh, and when this happens does the browser hang, requiring you to force quit, or is it just that the page doesn't load?
(Reporter)

Comment 3

11 years ago
Well, this is interesting. I re-installed 1.5.1 (from the the same dmg as the first time) to run the diagnostics app, and everything now works as it should. I checked all sites I had tried before and there were no problems. As far as the odd behavior before, no the browser didn't hang, the page simply didn't load. I went ahead and ran the diagnostic, but when I tried to attach it, I got a "File too large message". It's 1.2mb, if you still need/want it, I can email to you.

Comment 4

11 years ago
(In reply to comment #3)
> if you still need/want it, I can email to you.

Please do; if nothing else I'd like to find out why it's so large so I can update the diagnostic tool to trim more aggressively.

Comment 5

11 years ago
Nothing telling in the logs about what happened (although I do know why your log was huge, and have fixed the diagnostic tool, so that was helpful; thank you).

You have CamiTools installed; it's unlikely to be the problem, but CamiTools is known to break Camino 1.5 in a variety of other ways if you use certain options, so I'd suggest removing it. There's also MOAB.ape, which has the potentially to have broken something; I didn't follow what exactly they patched around.

It's also possible that it was a transient problem with the system itself trying to display the "Camino has changed" dialog and failing to for some reason.

Closing WFM, based on comment 3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.