Unreleased Java Memory [on tab close] causes Out-Of-Memory in Java and Fox Crash

VERIFIED INCOMPLETE

Status

()

Firefox
General
--
critical
VERIFIED INCOMPLETE
11 years ago
7 years ago

People

(Reporter: john ruskin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-06-26)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

When closing tabs or windows, where that tab had an active Java script with memory committed, FOX does not instruct any release of that memory.  On subsequent Java activity from another tab or window, this unreleased memory causes an Out Of Memory error in Java, a crash of Java, a crash of Fox, and a Fox crash which does not report to Talkback and leaves a memory ghost that must be manually closed.

This is a more specific description of what I think is a broader FOX bug, than what is reported as bug 392187

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
Fox and/or Java should release the committed memory that Java uses.
what version of Java are you using? (doing about:plugins in the URL bar should tell you)
(Reporter)

Comment 2

11 years ago
SE 6 U2

I note my own confusion when I see listings collections of applets and bean versions [variants of 1.3, 1.4, and 1.5, and 1.6, etc., in the listings]

Comment 3

11 years ago
Can you give us an example page where you see this. Also you seem to be confusing JavaScript and Java.

http://simple.wikipedia.org/wiki/Java_programming_language
http://simple.wikipedia.org/wiki/JavaScript
(Reporter)

Comment 4

11 years ago
http://www.ssd.noaa.gov/goes/east/tatl/loop-wv.html, is one example

This URL opens Java.   This URL's response to the behavior I note above is listed in the bug 392187, noted above.  That bug has an attachment which describes the specific Java errors produced.   I assumed that since the Java logo comes up, and a new small icon appears, and this kind of HTML coding appears
     <applet codebase=http://www.ssd.noaa.gov/goes/java height=600 archive=aniscode.jar width=1150 code=AniS.class>
that it was Java, and not a javascript. 

Looking at the about:plugins, i was surprised/confused, in that version numbers for the variants seemed to include past version numbers for Java [i.e., 1.5, 1.3, etc.]
(Reporter)

Comment 5

11 years ago
Ah.  Now I see your point.   My original comment should have said ". . . active Java applet . . ."   My error.
(Reporter)

Comment 6

11 years ago
I shared this error with the webmaster for NOAA/NHC.   [see, again, bug 392187]  They make this comment, in return [Source: Java Looping programmer/expert at NOAA/NHC, via the site's webmaster]:

"This user needs to set his memory allocation to "-Xmx256m" in his Java properties as discussed at: http://www.ssec.wisc.edu/visit/AniS/plugin_info.html "  

Their suggestion to increase the memory allocation seems like it will only delay the ultimate onset of the errors and crash.

I also note that this suggestion has been around for a long while, for earlier problems with browsers and earlier versions of Java.   This increase, as I recall, was needed when applets were larger than the [then] default heap size of 64k.   It is my understanding that the default is now 128k.

I seem to remember these same crashes in earlier version of Fox, and with earlier versions of Java; and have a vague sense that back then the increase only delayed the ultimate crash if one viewed different sets of the images.

Comment 7

9 years ago
do you still see problem if you use current beta, latest version of all plugins (for example flash v10 - check using about:plugins), java (1.6_0_13), etc
started in safe mode
 https://support.mozilla.com/en-US/kb/Safe+Mode
- latest beta
 http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: closeme 2009-06-26
(Reporter)

Comment 8

9 years ago
Since I haven't seen the crash in a while, I have not been checking to see if this BUG's distinct reported problem, the failure to release memory [with or without a crash, occurs.

Next I get into the NOAA site, I will see what happens with the memory -- i.e., on closing a tab with Java activity in it.
No Reply, INCO
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.