reftest for bug 322461 leaks nsStringBuffers

RESOLVED DUPLICATE of bug 393329

Status

()

Core
XSLT
P1
normal
RESOLVED DUPLICATE of bug 393329
11 years ago
11 years ago

People

(Reporter: Robert Sayre, Assigned: peterv)

Tracking

({memory-leak})

Trunk
mozilla1.9alpha8
memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
XPCOM_MEM_LEAK_LOG shows nsStringBuffers leaking through StringResult. Will attach the two stacks that show this leak.
(Reporter)

Comment 1

11 years ago
Created attachment 277608 [details]
leak in txExprParser::createAVT
(Reporter)

Comment 2

11 years ago
Created attachment 277610 [details]
leak in txExecutionState::init
Keywords: mlk
(Assignee)

Updated

11 years ago
Assignee: nobody → peterv
(Assignee)

Comment 3

11 years ago
I think this will be fixed by the patch for bug 393329.
Status: NEW → ASSIGNED
Depends on: 393329
OS: Linux → All
Priority: -- → P1
Hardware: PC → All
Target Milestone: --- → mozilla1.9 M8
Version: unspecified → Trunk

Updated

11 years ago
Summary: reftest for bug 322461 leaks → reftest for bug 322461 leaks nsStringBuffers
(Assignee)

Comment 4

11 years ago
Going to mark this duplicate of bug 393329. Robert, would be good to know if the leak went away for you too :-).
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
No longer depends on: 393329
Flags: blocking1.9?
Resolution: --- → DUPLICATE
Duplicate of bug: 393329
You need to log in before you can comment on or make changes to this bug.