nsINavBookmarkObserver's onItemVisit called too many times

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
P3
normal
RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: cesar, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
When I visit a website that I have bookmarked and tagged, the nsINavBookmarkObserver's onItemVisit() method gets called once for the visit, and then once again for each tag. So if I there are two tags, the observer gets called 3 times.

Don't know if this is a bug, or if I am doing this wrong. So setting it as unconfirmed.
(Reporter)

Comment 1

10 years ago
Created attachment 278090 [details]
testcase

Here are the steps to reproduce. Do this using trunk build or a nightly :
1. Visit http://example.com/
2. Bookmark the site and tag it as foo and bar
3. Open up the html file attached, and accept the extended js privileges
4. Open up a new tab and visit http://example.com/
5. Wait about a second or two

Actual Results :
Many alert boxes telling you that you are visiting a bookmarked page

Expected Results :
A single alert box telling you that you are visiting a bookmarked site
this occurs because tags are stored in the bookmarks system, and internally to the service each tagged uri appears as a bookmark.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Priority: -- → P3
Hardware: PC → All
Target Milestone: --- → Firefox 3
Target Milestone: Firefox 3 → ---
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
This should be fixed, we filter tags before notifying now.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.