Sending of messages in the background

RESOLVED DUPLICATE of bug 126140

Status

--
enhancement
RESOLVED DUPLICATE of bug 126140
11 years ago
11 years ago

People

(Reporter: mvanr, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: version 2.0.0.6 (20070728)

When sending messages, Thunderbird keeps the compose pane up until the message has been sent via SMTP.  Although you can move the compose/progress window to the back (so that you can carry on working with other messages), this is counter-intuitive.  The windows also clutter the desktop and give the (false) impression that Thunderbird is "slow" when compared to other email clients.

It would be great if all messages could go via the "unsent" queue in the background.  One easy way to do this would be with two preferences: "always send later" (which would make the send button behave like the send later button), and "automatically send unsent messages while online".


Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
Does setting mailnews.show_send_progress to false give you the preferred behaviour? 
(Reporter)

Comment 2

11 years ago
No.  If you set it to false, TBird does not pop up the "Sending message" dialog, but it still shows the progress in the compose window in the foreground, while it's doing the SMTP.  If you're sending a large message or a message with large attachements, it can take a long time to complete the send.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 126140
You need to log in before you can comment on or make changes to this bug.