Shutdown assertion in places: "ASSERTION: QueryInterface needed:"

RESOLVED DUPLICATE of bug 392980

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 392980
11 years ago
8 years ago

People

(Reporter: Robert Sayre, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 277723 [details]
the assertion

I get this about half the time when visiting http://www.rapidshare.com and then closing the browser.
800 NS_IMPL_ISUPPORTS3(FaviconLoadListener,
801                    nsIStreamListener, // is a nsIRequestObserver
802                    nsIInterfaceRequestor,
803                    nsIChannelEventSink)

That's just wrong.  Sadly, the author and reviewer of that mess are all gone.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392980
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.