If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

addcheckin.pl is consuming huge amounts of memory on lounge

RESOLVED DUPLICATE of bug 52573

Status

Webtools Graveyard
Bonsai
P3
critical
RESOLVED DUPLICATE of bug 52573
18 years ago
a year ago

People

(Reporter: Risto Kotalampi, Assigned: Dawn Endico)

Tracking

Details

(Reporter)

Description

18 years ago
addchekin.pl is eating a lot of memory again. Last time this was because of 
MozillaClassic hook that needed to be updated every time (or something, ask 
Terry). Now I see this happening again... addchekin.pl is eating up to 46M of 
memory _each_. This is very bad when the tree opens (like this afternoon). The 
load of lounge has been around 17 because of this for last minutes.
(Reporter)

Comment 1

18 years ago
Terry fixed this yesterday. Problem is same as earlier. newlayout and Mozilla 
Classic trees grow in time and at times when tree opens addchekin.pl's grow 
pretty big and consumes all resources.

According to Terry solution to this is to close newlayout & Mozilla Classic and 
reopen it once a week automatically.

Moving this to Dawn because this is bonsai instance issue.
Assignee: tara → endico
(Reporter)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 2

15 years ago
If this is being handled by cron job now, let's close out this bug as being
dealt with.  The long term solution is to not have the
dolog->handleCheckinMail->addcheckin mess exist anymore and instead write
directly to the DB from CVSROOT (see the bonsai project page for more info)
this bug is older, but the other bug has better discussion

*** This bug has been marked as a duplicate of 52573 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.