attachment X should not been converted on fly when \n is inserted

VERIFIED DUPLICATE of bug 105865

Status

()

VERIFIED DUPLICATE of bug 105865
11 years ago
11 years ago

People

(Reporter: damian.publicemail, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
see bug 393307 comment 0

what I wrote was:
6. import events from attachment
<new line here>
7. move 

and bugzilla converted it into link to attachment no 7, well it makes sense as long as there is no enter between attachemnt and 7, because then my intention was not to create link to this attachment, but use number for steps like in this case

Comment 1

11 years ago
no. wrong fix.

the problem is that i can write something very long like this and if i'm very unlucky my browser will split it between the word and then number. This silly comment by me shows how this will break: attachment 5 [details].

The right fix eventually is to teach bugzilla to recognize when there's a step list.
Whiteboard: DUPEME

Comment 2

11 years ago
:(, that comment didn't work. I think we changed the line wrapping policy. In the old days, bugzilla relied on web browsers to do line wrapping which means users would have lines broken based on whatever their browser felt like doing. This means that at least legacy comments in bugzilla.mozilla.org will suffer if we do this. 

Generally speaking, while this is annoying, it used to be harmless.

Until someone added the magic [edit] thing. :( -- keyword: regression.
Keywords: regression

Comment 3

11 years ago
Not a regression.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 105865
(Reporter)

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.