Closed Bug 393521 Opened 14 years ago Closed 14 years ago

Scrollbar visible all the time, even DIV is "hidden" by setting z-index to negative.

Categories

(Firefox :: General, defect)

2.0 Branch
PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 187435

People

(Reporter: borisov.gleb, Unassigned)

Details

(Keywords: testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

When I set negative z-index to DIV that have a scrollbars - it's not applied to scrollbars. When DIV hidden via css rule "display:none" - scrollbars hiding and all right.

This bug related *only* for Mac-version of FF. Not applied for Win-version.

Reproducible: Always

Steps to Reproduce:
1. Create DIV with style="width:100%; height:100%; background-color:#f00;"
2. Create another DIV with style="width:100px; height:100px; overflow-x:auto; overflow-y:scroll; position:absolute; top: 100px; left: 100px;"
3. Put some content to second DIV to make it scrollable.
4. Set first DIV z-index to 10
5. Set second DIV z-index to negative 
Actual Results:  
See lonely scrollbar on the first DIV. :(

Expected Results:  
I should see only first DIV w/o all that stuff.

Mac OS X 10.4.10
Apple MacBook Core2Duo Late
Firefox (without any extensions and themes)
No other mozilla products.
Please attach a minimal testcase to this bug with the 'Add an attachment' link. Thanks!
Version: unspecified → 2.0 Branch
Done.
In FF on mac - scrollbars visible.
In FF on win - scrollbars hidden.

In safari on mac and on ie on win - hidden.
Keywords: testcase
Are you able to test a firefox trunk build (from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ ) and see if the problem is fixed there?
Yes, this problem fixed in 3.0a8pre.
Should I expect fixing this bug in 2.x branch?
If it is a regression on the 2.0 branch (ie: worked on an older version on 2.0 but no longer works on 2.0.0.6) then it would be a candidate for being fixed.

But if it's always been present since Firefox 2.0 release, then it's unlikely to get patched.
It is an age old bug on Gecko. And yes, it is fixed on trunk.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 187435
You need to log in before you can comment on or make changes to this bug.