should descriptions, string annotations be searched when we url bar autocomplete?

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
12 years ago
4 years ago

People

(Reporter: moco, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

should descriptions, string annotations, and tag names be searched when we url bar autocomplete?

looking for feed back from the UI gurus.  if this should become three bugs, let me know.

note, we have plans to highlight the matching text in the url bar results (bug #387717), but with descriptions, text annotations, tag names, etc, the matching text would not be visible.
I think it is important that the user understands why their search results match against the search that they entered.  So if we decide we want to match against descriptions or text annotations, we need to find a way of showing that.

This bug is related to bug #393508
updating summary, tag searching was implemented.
Summary: should descriptions, string annotations, and tag names be searched when we url bar autocomplete? → should descriptions, string annotations be searched when we url bar autocomplete?

Comment 3

12 years ago
Should this be added to the meta bug 405745 '[meta] improve url bar
autocomplete results'?
Is the bug 406246 a duplicate of this current bug?

Updated

11 years ago
Duplicate of this bug: 406246
we are searching tags already, as comment 2 states. I don't think we should be searching more than what we do today cause the risk to add too many unrelated items in that small space is high, then we could lose value.
Moreover description and annotations are something that the user may have never seen for a page, so the likely he might remember a match against those is very low.
Finally add-ons or pages could set those to cheat the system.
I don't think the gain is worth the development time here.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.