If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

bookmarked results be weighted higher in the url bar autocomplete results

RESOLVED FIXED

Status

()

Firefox
Address Bar
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

({uiwanted})

Trunk
uiwanted
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

should bookmarked results be weighted higher in the url bar autocomplete results?

within a chunk of time, we order by visit count.

should a bookmarked url be given priority?

note, soon you will see stars next to bookmarked items (see bug #387718)
mconnor writes:  I think they should probably be searched and weighted higher. 
Flags: blocking-firefox3?
Summary: should bookmarked results be weighted higher in the url bar autocomplete results? → bookmarked results be weighted higher in the url bar autocomplete results
mconnor also writes:  I think starred+ is an implicit "show me these results first" so I'd go with that.  Though I think frecency needs to be truly global, so I'd want to account for that as we sort (see my wiki braindump http://wiki.mozilla.org/User:Mconnor/PlacesFrecency) 
I don't think tweaking the frecency algorithm blocks, per se, but we definitely want to figure this out and get a decision here.
Flags: blocking-firefox3? → blocking-firefox3-
Keywords: uiwanted
Whiteboard: [wanted-firefox3]
If we weight bookmarked results higher, it needs to be before we re-rank based on adaptive learning, and not after.  For instance, if every time I type "f" I go to facebook.com, but it isn't bookmarked, it still needs to be the first result.
Blocks: 405745

Comment 5

10 years ago
Seems to be a duplicate of bug 394066.

Comment 6

10 years ago
I believe bug 394066 refers to visiting bookmarked pages while this one is ranking bookmark results in general (not necessarily having a visit yet).
Depends on: 393570
bret was asking for something like this.

my understanding of his request was:

"when I star something, I usually intend for that be the result I want to visit again.  so I'd like starred items to show up first in the ac results."

previously, mconnor wrote:  "I think starred+ is an implicit "show me these results first" so I'd go with that".

this bug is about that, but as faaborg commented, we should do this before adaptive learning (see edward lee's ongoing work.)

I would recommend waiting for global frecency (see bug #394038) to make this change.

Depends on: 394038
Here is what I am worried about: the star is meant to mean "don't forget about this page."  We are making the starring interface light weight so it is easy to star thousands of pages, and we are not adding starred pages to the bookmarks menu so it doesn't become cluttered (also hoping to create an environment where you star thousands of pages).  But if starred pages always push out the results you were otherwise looking for, you now have an incentive to star less pages, or only star a page if you actually plan on going back to it a lot.

>previously, mconnor wrote:  "I think starred+ is an implicit "show me these
>results first" so I'd go with that".

A lot of our other decisions are based on the behavior that users are going to star pages that they thought were interesting, but potentially don't intend to visit a lot, potentially only one more time, far in the future.  For instance I just starred an article about "50 best blog posts about design" that I might want to read later at some point if I am bored.  But I don't want that entry to appear above every bugzilla title that contains "design", all of which have much higher frecency.

There are a lot of ways we can guess how to make the results better, like weighting bookmarked pages higher, or weighting prefix matches before suffix matches.  But overall I think we should just land edward's adaptive learning patch, and let the results organically morph to the user's behavior, since these guesses on how to artificially force better results are somewhat arbitrary and based on assumed user behavior.  This way, if you think certain star results should appear first, you will end up selecting them, and they will start to appear first.
Flags: wanted-firefox3+
Whiteboard: [wanted-firefox3]
fixed in bug 394038.

re comment #8: the weighting for bookmarks is tune-able via a pref, so if we see starred items pushing out better matches, then we can change the default.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.