Last Comment Bug 393597 - Drag events cannot update chrome while dragging over content on Mac OS
: Drag events cannot update chrome while dragging over content on Mac OS
Status: RESOLVED WORKSFORME
: testcase
Product: Core
Classification: Components
Component: XUL (show other bugs)
: 1.8 Branch
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-24 12:35 PDT by Jorge Villalobos [:jorgev]
Modified: 2012-03-09 16:15 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase extension (1.40 KB, application/x-xpinstall)
2007-08-24 12:35 PDT, Jorge Villalobos [:jorgev]
no flags Details

Description Jorge Villalobos [:jorgev] 2007-08-24 12:35:56 PDT
Created attachment 278102 [details]
Testcase extension

We stumbled across this problem while working on an extension. We found out that if you start a drag from a web page, the draggesture and dragover event handlers are called correctly, but any chrome changes done in these handlers are not applied until the drag is canceled, or the drag occurs over the chrome. We know the handlers are being called because we logged the calls to disk with a timestamp.

Tested on:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

I'm attaching a testcase extension. To test simply install the extension and begin a drag. The extension should display and update the current pointer position in the status bar. I tested this on Windows and Linux, and it worked as expected. On Mac OS, the position is only updated while dragging over the chrome.
Comment 1 Jorge Villalobos [:jorgev] 2012-03-09 16:15:45 PST
I can no longer reproduce this bug.

Note You need to log in before you can comment on or make changes to this bug.