selected identity's account name is hard to see: grey text with blue highlight

RESOLVED FIXED in Thunderbird 58.0

Status

--
minor
RESOLVED FIXED
11 years ago
11 months ago

People

(Reporter: moco, Assigned: Paenglab)

Tracking

Thunderbird 58.0

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug][lang=js])

Attachments

(2 attachments, 3 obsolete attachments)

selected identity's account name is hard to see:  grey text with blue highlight

here comes a screen shot.

is there way we could use a lighter "when selected" color for the selected identity's account name?

Updated

11 years ago
Severity: normal → minor
OS: Windows XP → All
Hardware: PC → All
I came across a similar issue with the firefox url bar, which uses another color (#55556) for the comment, like tbird does:

http://lxr.mozilla.org/seamonkey/source/mail/themes/qute/mail/compose/messengercompose.css#337

I bet that what we need is an additional css row that overrides that rule and sets the font color to HighlightText when the item is selected.

for the url bar, I think this happens here:
http://lxr.mozilla.org/seamonkey/source/toolkit/themes/winstripe/global/autocomplete.css#210

Comment 3

10 years ago
an interesting aspect to this is it isn't clear why the account name is different.  Or I suspect to the novice user, even what "it" is.

Comment 4

10 years ago
also seen in "view" picker in 3-pane

Comment 5

10 years ago
Seems the css for the comment is actually not doing anything...

http://mxr.mozilla.org/seamonkey/source/mail/themes/qute/mail/compose/messengercompose.css#336
336 .autocomplete-treebody::-moz-tree-cell-text(comment) {
337   color: #555566;
338 }

Updated

10 years ago
Whiteboard: [good first bug]

Comment 6

8 years ago
andreas...

(In reply to comment #5)
> Seems the css for the comment is actually not doing anything...
> 
> http://mxr.mozilla.org/seamonkey/source/mail/themes/qute/mail/compose/messengercompose.css#336
> 336 .autocomplete-treebody::-moz-tree-cell-text(comment) {
> 337   color: #555566;
> 338 }

(In reply to comment #4)
> also seen in "view" picker in 3-pane

perhaps also bug 312246

Comment 7

6 years ago
Created attachment 726837 [details] [diff] [review]
Selected identity's account preview fixed

Fixed selected identity's account preview changing it's color from brown to white.
Attachment #726837 - Flags: review?

Comment 8

6 years ago
Comment on attachment 726837 [details] [diff] [review]
Selected identity's account preview fixed

diff --git a/mail/themes/qute/mail/compose/messengercompose-aero.css b/mail/themes/qute/mail/compose/messengercompose-aero.css
--- a/mail/themes/qute/mail/compose/messengercompose-aero.css
+++ b/mail/themes/qute/mail/compose/messengercompose-aero.css
@@ -360,17 +360,18 @@ toolbox[labelalign="end"] > toolbar[mode
   -moz-border-end-width: 0;
   -moz-border-start: 1px solid #A9B7C9;
   -moz-border-left-colors: none;
   -moz-border-right-colors: none; /* for rtl -moz-border-start */
   background-color: transparent;
 }
 
 #attachmentBucketSize {
-  color: #888a85;
+  /*color: #888a85;*/
+  color: #FFFFFF;
 }
 
 /* ::::: attachment reminder ::::: */
 
 #attachmentNotificationBox > notification > .notification-inner {
   border: none;
   border-top: 1px solid ThreeDShadow;
 }
@@ -436,17 +437,18 @@ treechildren::-moz-tree-image(remote-err
   -moz-margin-start: 2px;
   -moz-margin-end: 5px;
   list-style-image: url("chrome://messenger/skin/addressbook/icons/remote-addrbook-error.png");
 }
 
 /* ::::: addressing widget ::::: */
 
 .autocomplete-treebody::-moz-tree-cell-text(comment) {
-  color: #555566;
+  /*color: #555566;*/
+  color: #FFFFFF;
 }
 
 @media (-moz-windows-default-theme) {
   .autocomplete-treebody::-moz-tree-cell-text(selected) {
     color: -moz-DialogText !important;
   }
 }
 
diff --git a/mail/themes/qute/mail/compose/messengercompose.css b/mail/themes/qute/mail/compose/messengercompose.css
--- a/mail/themes/qute/mail/compose/messengercompose.css
+++ b/mail/themes/qute/mail/compose/messengercompose.css
@@ -374,17 +374,17 @@ treechildren::-moz-tree-image(remote-err
   -moz-margin-start: 2px;
   -moz-margin-end: 3px;
   list-style-image: url("chrome://messenger/skin/addressbook/icons/remote-addrbook-error.png");
 }
 
 /* ::::: addressing widget ::::: */
 
 .autocomplete-treebody::-moz-tree-cell-text(comment) {
-  color: #555566;
+  color: #FFFFFF;
 }
 
 #addressingWidget {
   -moz-user-focus: none;
   -moz-appearance: none;
   width: 0;
   border: none;
   background-color: transparent;

Comment 9

6 years ago
Created attachment 726886 [details] [diff] [review]
Selected identity's account preview fixed

Fixed selected identity's account preview changing it's color from brown to white
Attachment #726886 - Flags: review?
Comment on attachment 726837 [details] [diff] [review]
Selected identity's account preview fixed

Assuming this patch is obsolete as its included in the second one.
Attachment #726837 - Attachment is obsolete: true
Attachment #726837 - Flags: review?
Comment on attachment 726886 [details] [diff] [review]
Selected identity's account preview fixed

This needs a ui-review as its first action.
Attachment #726886 - Flags: review? → ui-review?(bwinton)
This is not an issue in the current Daily. What is being addressed here?
Flags: needinfo?

Comment 13

6 years ago
I think https://bug393641.bugzilla.mozilla.org/attachment.cgi?id=278153 illustrates it pretty well. It's still an issue on current trunk. (At least on linux.)
Flags: needinfo?

Comment 14

6 years ago
Oh, can we get a screenshot of the patch in action? The same changes to the linux theme didn't seem to have any effect.
Comment on attachment 726886 [details] [diff] [review]
Selected identity's account preview fixed

I like this in theory, but there are a couple of things I want to see before it gets a ui-r+…

1) It looks like you've only made the changes for Windows, which makes it really hard for me to test on my Mac…  ;)
2) We've renamed all the directories so "qute" is now "windows".  This makes things more understandable, but sadly breaks your patch.
3) Don't bother commenting out the old colours, just replace them.  If we need to see what they were, we can use the version control system.  :)

I look forward to the next version of your patch!

Thanks,
Blake.
Attachment #726886 - Flags: ui-review?(bwinton) → ui-review-

Comment 16

5 years ago
Luiz?
Assignee: nobody → lhsantosazs

Comment 17

4 years ago
I would like to take it on as my first bug. It seems to me that  the change
 .autocomplete-treebody::-moz-tree-cell-text(comment) {
-  color: #555566;
+  color: #FFFFFF;
 }
is having no effect on the thunderbird. Is that so? Also, what is desired change in the color?(if there is some specific colour.)
The color of highlight depends on the platform(for linux mint it is green).
(Assignee)

Comment 18

4 years ago
Thank you for taking this bug. If you have questions, ask them here or through IRC in #maildev.

It has no effect because it's a menupopup and not a tree. As color you can use HighlightText. It's the same color as the email address has when selected but it's still italic and the difference is enough.

Best would be you add the needed rule to messengercompose.css. What you need is to override the color of this rule: http://mxr.mozilla.org/comm-central/source/mozilla/toolkit/themes/windows/global/menu.css#75 I've chosen the windows path but where also linux and osx.
Assignee: lhsantosazs → kris.kr296

Updated

a year ago
Whiteboard: [good first bug] → [good first bug][lang=js]

Updated

11 months ago
Duplicate of this bug: 312246
(Assignee)

Comment 20

11 months ago
Created attachment 8911551 [details] [diff] [review]
Bug393641.patch

This fixes the issue by using the HighlightText instead GrayText when hovering the item. I also fixed the attachmentBucketSize color to use GrayText instead of a fixed color to better work with dark themes an High Contrast themes.
Assignee: kris.kr296 → richard.marti
Attachment #726886 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8911551 - Flags: review?(mkmelin+mozilla)

Comment 21

11 months ago
Comment on attachment 8911551 [details] [diff] [review]
Bug393641.patch

Works fine for me. HighlightText seems to be the logical choice, although something a little less bright would be better. Perhaps add some opacity?
Attachment #8911551 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Comment 22

11 months ago
Created attachment 8911592 [details] [diff] [review]
Bug393641.patch

Added a opacity of 0.7 to make it less bright.
Attachment #8911551 - Attachment is obsolete: true
Attachment #8911592 - Flags: review+
(Assignee)

Updated

11 months ago
Keywords: checkin-needed

Comment 23

11 months ago
(In reply to Richard Marti (:Paenglab) from comment #22)
> Added a opacity of 0.7 to make it less bright.
Nice!

Comment 24

11 months ago
Jorg, please don't steal non-urgent reviews without asking.

Comment 25

11 months ago
I've been doing heaps of theme reviews lately, so this was a good match.

Comment 26

11 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/a7227c349261
Make .menu-description better visible on hover. r=jorgk
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

11 months ago
Target Milestone: --- → Thunderbird 58.0
You need to log in before you can comment on or make changes to this bug.