"###!!! ASSERTION: QueryInterface needed: 'query_result.get() == mRawPtr'" in nsRequestObserverProxy::Init

RESOLVED DUPLICATE of bug 392980

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 392980
11 years ago
11 years ago

People

(Reporter: Eli Friedman, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Per summary.  Steps to reproduce: turn on "Work Offline" in Firefox, then attempt to visit any page.

It appears the issue is that FaviconLoadListener cannet be QueryInterfaced to nsIRequestObserver; it implements an inherited interface, nsIStreamListener, so it can be implicitly cast to an nsIRequestObserver, but the QueryInterface implementation only knows about nsIStreamListener.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392980
You need to log in before you can comment on or make changes to this bug.