Opening saved search timeouts too easily, spawns multiple IMAP connections

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Jari Juslin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fi; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: 2.0.0.6 (20070728)

Opening saved search on big folder causes Thunderbird to reopen IMAP connection every minute, creating lots of unnecessary connections and thus killing IMAP server performance.

When saved search covers folders with like 8000-15000 messages, going through the messages causes a lot of IO load in IMAP server, which is to be expected. When it goes wrong is that Thunderbird first asks too much data at a time, thus generating slow response as server starts to scan the messages, and then drops the connection before server gets to reply, opens new connection and makes similar request again.

The end result is that the search stalls as every new connection is even slower, as the old IMAP connections are trying to finish whatever they were doing. On the worst times I see 7 to 12 IMAP connections just for a single Thunderbird instance.

Reproducible: Always

Steps to Reproduce:
1. Make saved search for a folder with at least 8000 messages; select it to search for message bodies and for the search to be done online.
2. Open such a search folder.

Actual Results:  
Thunderbird times out the connection every minute and creates a new connection.


Expected Results:  
Thunderbird should do the queries in the pace the server can handle and not drop the connection while the request is being served.

IMAP server in question is dovecot running on an Ubuntu Linux machine, messages are stored in Maildir format.

Comment 1

11 years ago
I have a similar problem with continued connection timeouts eating server processes. In my case it is just reading a large folder over a sometimes slow connection.

Is it possible that the connection is not properly reset when the connection times out?

Comment 2

10 years ago
Will make test agains 20K+ messages folder, but definitely can't reproduce it with my dovecot 1.x and 2500 messages.
(Reporter)

Comment 3

10 years ago
Ok, I upgraded my server hardware a while ago and now with new hardware I cannot get this to reproduce anymore (tested with 23k messages). The old machine had very little memory (256M) so I suspect it had to swap heavily thus making the dovecot slower with huge folders than it normally gets.

For me the problem is now solved with beefier hardware, so unless someone else has the same problem, I propose we close this bug for now.

Comment 4

10 years ago
I will mark it WORKSFORME, in case somebody else run into this problems we can reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.