Assert error presented in 0.7 for snoozed tasks created in 0.5

RESOLVED WORKSFORME

Status

Calendar
Alarms
RESOLVED WORKSFORME
11 years ago
6 years ago

People

(Reporter: Omar Bajraszewski, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
Disabling dates and alarm for a snoozed task created in Sunbird 0.5 causes this error in Sunbird 0.7:
Error: Assert failed: [calAlarmService] Could not determine alarm time for item: My task
1: ASSERT
2: 
3: 
4: onGetResult
5: queueItems

Source file: file:///C:/Documents%20and%20Settings/Omar/Pulpit/Sunbird%200.7/js/calUtils.js
Line: 647


Steps to reproduce:
1)create a task with start and due date and enabled alarm with Sunbird 0.5
2)Wait until alarm fires
3)Snooze for 5 minutes
4)Edit the task: disable start and due dates and alarm
5)Upgrade to nightly Sunbird 0.7 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7pre) Gecko/20070825 Calendar/0.7pre)
6)Start Sunbird 0.7 after 5 minutes
7)Look at the error console

Result:
Assert error in console

Expected Results:
No error in console

Comment 1

11 years ago
The message was added with Bug 349715 on purpose to not just silently leave the function if no alarm time can be found. Therefore the message is valid. 

But the checkin from Bug 389245 changed it from a simple developer message to a fatal error message that is reported to the Error Console. In my opinion this is a little bit overkill.

Comment 2

11 years ago
IMO the problem is more that the event dialog (or calTodo.js if feasible) should enforce consistency for the item, i.e. they need to remove the alarm if neither DTSTART nor DUE is present (referring to RFC 2445, 4.8.6.3 Trigger). I'd vote to leave that error in, because essentially *invalid* iCalendar has been generated and may break other apps when exporting that data to them.

Comment 3

9 years ago
Works for me using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090125 Calendar/1.0pre. There is no assertion displayed anymore.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.